Diagnose my nokia ??

loady

DW Member +
Joined
Jul 27, 2005
Messages
1,328
Likes
3
#1
Could someone please point me in the right direction to get the info needed by someone to be able to tell if my nokia is fuggered...i will post it hear for anyone to muse over.

thanks.
 

loady

DW Member +
Joined
Jul 27, 2005
Messages
1,328
Likes
3
#2
Ok i have searched around, "null modem cable" and "boot log" are not really specific enough to find the info i need, "boot log" search turned up subjects like "do you believe in aliens" and lots of other non topic threads, i have d/l command centre but cant see how i use it with null modem cable to get log, i know i can use ifa but not sure if i have top be flashing the box at the same time to get the boot log ? i dont want to mess around with my new stable image.
 

mgb

Inactive User
Joined
May 9, 2005
Messages
3,939
Likes
29
#3
Install plain bootmanager, connect box and pc via null modem cable, disable all option except com 9600 in the bootmanager options, click on start, plug in your box.
If you right click on the com terminal you can copy the output to the clipboard.
 

loady

DW Member +
Joined
Jul 27, 2005
Messages
1,328
Likes
3
#4
Thanks for that mgb, anyone got that on thier hard drive as a search in downloads has not turned anything up. Please upload it.

Thanks, i will post log in here when i get it.
 

loady

DW Member +
Joined
Jul 27, 2005
Messages
1,328
Likes
3
#6
Hrrmphh, i took it to be 2 words which probably didnt help matters, never the less, thank you.

I have the program going and have filled in my ip for box and left all other settings......when i pushed start i got this message "Das NFS-root verzeichnis muB existieren" which looks like something does not exist ?......do i need to be flashing the box to get the boot log off ?
 

loady

DW Member +
Joined
Jul 27, 2005
Messages
1,328
Likes
3
#7
Ok, i fiddled with it and unchecked the box which mentions NFS and it seems to have started, been going for 2 minutes now and is going over a wireless network.

EDIT: Bottom right of window it says pinging dbox ok (2ms) bottom left it just says started then next to that it says status NFS 0 (RX) - 0 (TX)
On the com windows the cursor has shot down to bottom but no data in screen, lights are flashing on my wireless card but nothing seems to be happening, surely a simnple log does not take this long to do ?
 

mgb

Inactive User
Joined
May 9, 2005
Messages
3,939
Likes
29
#8
You need the log via null modem cable. The whole network crap should be disabled in the bootmanager options..
 

loady

DW Member +
Joined
Jul 27, 2005
Messages
1,328
Likes
3
#9
unchecked the box regarding the ethernet, but still nothing. svreen shot attached.
 

DessertDog

Inactive User
Joined
Jul 11, 2004
Messages
1,467
Likes
1
#10
you need to use a Null Modem cable m8 from pc to box
where it says 57600 that needs to be 9600 if remember right m8 also make sure its the correct com port
 

loady

DW Member +
Joined
Jul 27, 2005
Messages
1,328
Likes
3
#12
yep...null modem cable is connected and have changed to 9600, there is only one serial port on this laptop and that shows up in bootmanager as com 1 or com 3, i have tried both. if i delete the ip address from the box i get an error message, i am assuming the ip of the dbox should be ebtered.
 

loady

DW Member +
Joined
Jul 27, 2005
Messages
1,328
Likes
3
#14
its listed as com port 1 and there are no yellow exclamations. should i unplug the the wireless network card so i doesnt try to ping the dbox ?
 

mgb

Inactive User
Joined
May 9, 2005
Messages
3,939
Likes
29
#15
The network doesn't hurt.
Something is wrong with the serial connection to the box or you didn't plugin your box. On a already running box you don't see a bootlog.
 

loady

DW Member +
Joined
Jul 27, 2005
Messages
1,328
Likes
3
#16
are you saying i need to start the program running then turn on the box ? at present the box is already running and booted.
 

loady

DW Member +
Joined
Jul 27, 2005
Messages
1,328
Likes
3
#19
Heres where it seems to have got up to...and that is without the cable feed in.

C00C0864 C00CCA60 C00BA9E0 C00BAB8C C00BACF4 C00141F4 C0003A78
C0142FD4 C01437FC
C01395C8 C0002C00027C0 00000000 C000F0D8 C000F22C C000F5D4 C000F490 C0142D34
In interrupt handler - not synci2B0 C0004D1C
Kernel panic: Aiee, killing interrupt handler!
debug: DDF: Calibrating delay loop... debug: DDF: 67.79 BogoMIPS
debug: WATCHDOG RESET
debug: BMon V1.2 mID 01
debug: feID 7a gtxID 0b
debug: fpID 5a dsID 01-99.cc.82.07.00.00-bd
debug: HWrev 09 FPrev 0.81
debug: B/Ex/Fl(MB) 32/00/08
WATCHDOG reset enabled
dbox2:root> debug:
BOOTP/TFTP bootstrap loader (v0.3)
debug:
debug: Transmitting BOOTP request via broadcast
debug: Given up BOOTP/TFTP boot
boot net failed

Flash-FS bootstrap loader (v1.5)

Found Flash-FS superblock version 3.1
Found file /root/platform/nokia-dbox2/kernel/os in Flash-FS
debug: Got Block #0032

will verify ELF image, start= 0x800000, size= 152952
verify sig: 263
Branching to 0x40000


U-Boot 1.1.2 (TuxBox) (May 23 2004 - 21:44:01)

CPU: PPC823ZTnnB2 at 67.100 MHz: 2 kB I-Cache 1 kB D-Cache
Board: DBOX2, Nokia, BMon V1.2
Watchdog enabled
I2C: ready
DRAM: 32 MB
FLASH: 8 MB
Scanning JFFS2 FS: ........ done.
FB: ready
LCD: ready
In: serial
Out: serial
Err: serial
Net: SCC ETHERNET

Options:
1: Console on null
2: Console on ttyS0
3: Console on framebuffer
Select option (1-3), other keys to stop autoboot: 0
...............................................................
Un-Protected 63 sectors
### FS (jffs2) loading 'vmlinuz' to 0x100000
### FS load complete: 631075 bytes loaded to 0x100000
## Booting image at 00100000 ...
Image Name: dbox2
Image Type: PowerPC Linux Kernel Image (gzip compressed)
Data Size: 631011 Bytes = 616.2 kB
Load Address: 00000000
Entry Point: 00000000
Verifying Checksum ... OK
Uncompressing Kernel Image ... OK
Linux version 2.4.31-dbox2 ([email protected]) (gcc version 3.3.5) #25 Sa Jul
30 18:26:20 CEST 2005
On node 0 totalpages: 8192
zone(0): 8192 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Kernel command line: root=/dev/mtdblock2 rw console=ttyS0
Decrementer Frequency = 251625000/60
m8xx_wdt: active wdt found (SWTC: 0xFFFF, SWP: 0x1)
m8xx_wdt: keep-alive trigger installed (PITC: 0x2580)
Console: colour dummy device 80x25
Calibrating delay loop... 66.76 BogoMIPS
Memory: 30864k available (1076k kernel code, 368k data, 60k init, 0k highmem)
Dentry cache hash table entries: 4096 (order: 3, 32768 bytes)
Inode cache hash table entries: 2048 (order: 2, 16384 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 1024 (order: 0, 4096 bytes)
Page-cache hash table entries: 8192 (order: 3, 32768 bytes)
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
devfs: v1.12c (20020818) Richard Gooch ([email protected])
devfs: boot_options: 0x1
JFFS2 version 2.2. (NAND) (C) 2001-2003 Red Hat, Inc.
i2c-core.o: i2c core module version 2.6.1 (20010830)
i2c-dev.o: i2c /dev entries driver module version 2.6.1 (20010830)
CPM UART driver version 0.04
ttyS0 at 0x0280 is on SMC1 using BRGttyS1 at 0x0380 is on SMC2 using BRG2
pty: 256 Unix98 ptys configured
eth0: CPM ENET Version 0.2.dbox2 on SCC2, 00:50:9c:42:e6:b4
D-Box 2 flash driver (size->0x800000 mem->0x10000000)
D-Box 2 flash memory: Found 2 x16 devices at 0x0 in 32-bit bank
Intel/Sharp Extended Query Table at 0x0035
cfi_cmdset_0001: Erase suspend on write enabled
Creating 5 MTD partitions on "D-Box 2 flash memory":
0x00000000-0x00020000 : "BR bootloader"
0x00020000-0x00040000 : "FLFS (U-Boot)"
0x00040000-0x00800000 : "root (JFFS2)"
0x00020000-0x00800000 : "Flash without bootloader"
0x00000000-0x00800000 : "Complete Flash"
Linux video capture interface: v1.00
mice: PS/2 mouse device common for all mice
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 2048 bind 4096)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
cramfs: wrong magic
VFS: Mounted root (jffs2 filesystem).
Mounted devfs on /dev
Freeing unused kernel memory: 60k init
Starting pid 11, console /dev/console: '/etc/init.d/rcS'ti-call b
Using /lib/modules/2.4.31-dbox2/misc/event.o
event: $Id: event.c,v 1.12 2003/09/30 05:45:38 obi Exp $
Using /lib/modules/2.4.31-dbox2/misc/tuxbox.o
Using /lib/modules/2.4.31-dbox2/misc/dvb-core.o
Using /lib/modules/2.4.31-dbox2/misc/dbox2_i2c.o
[i2c-8xx]: mpc 8xx i2c init
[i2c-8xx]: adapter: 0
Using /lib/modules/2.4.31-dbox2/misc/dbox2_fp.o
Using /lib/modules/2.4.31-dbox2/misc/dbox2_fp_input.o
Using /lib/modules/2.4.31-dbox2/misc/avs.o
Using /lib/modules/2.4.31-dbox2/misc/saa7126.o
Detected STB:
Vendor: Nokia
Model: D-BOX2
Using /lib/modules/2.4.31-dbox2/misc/cam.o
$Id: cam.c,v 1.30 2004/01/10 16:36:34 alexw Exp $
Using /lib/modules/2.4.31-dbox2/misc/dvb_i2c_bridge.o
Using /lib/modules/2.4.31-dbox2/misc/avia_napi.o
$Id: avia_napi.c,v 1.18 2003/11/24 09:53:01 obi Exp $
DVB: registering new adapter (C-Cube AViA GTX/eNX with AViA 500/600).
dvb_i2c_bridge: enabled DVB i2c bridge to PowerPC 8xx I2C adapter
Using /lib/modules/2.4.31-dbox2/misc/cam_napi.o
$Id: cam_napi.c,v 1.8 2003/09/30 05:45:34 obi Exp $
Using /lib/modules/2.4.31-dbox2/misc/dbox2_fp_napi.o
Using /lib/modules/2.4.31-dbox2/misc/avia_av_alt.o
route: SIOC[ADD|DEL]RT: Network is unreachable
avia_av: $Id: avia_av_core.c,v 1.89 2004/02/27 22:17:44 obi Exp $
avia_av_event: $Id: avia_av_event.c,v 1.11 2003/10/26 16:32:51 obi Exp $
avia_av_proc: $Id: avia_av_proc.c,v 1.14 2004/01/21 20:02:29 carjay Exp $
Using /lib/modules/2.4.31-dbox2/misc/avia_gt.o
avia_gt_core: $Id: avia_gt_core.c,v 1.48 2004/12/20 01:01:22 carjay Exp $
avia_gt_core: autodetecting chip type... GTX
avia_gt_gtx: $Id: avia_gt_gtx.c,v 1.24 2003/09/30 05:45:35 obi Exp $
avia_gt_accel: $Id: avia_gt_accel.c,v 1.19 2003/09/30 05:45:35 obi Exp $
avia_gt_dmx: $Id: avia_gt_dmx.c,v 1.210 2004/06/26 16:08:15 carjay Exp $
avia_gt_core: masking unhandled irq reg 1 bit 11
avia_gt_core: masking unhandled irq reg 1 bit 13
avia_gt_ucode: loaded ucode v001A
avia_gt_ucode: ucode section filters disabled.
avia_gt_dmx: warning, misaligned queue 0 (is 0xFD200, size 65536), aligning...
avia_gt_gv: $Id: avia_gt_gv.c,v 1.39 2004/08/28 16:44:56 carjay Exp $
avia_gt_gv: set_input_size (width=720, height=576)
avia_gt_pcm: $Id: avia_gt_pcm.c,v 1.29 2004/01/29 19:38:20 zwen Exp $
avia_gt_pcm_set_rate(44100)
avia_gt_capture: $Id: avia_gt_capture.c,v 1.32 2003/09/30 05:45:35 obi Exp $
avia_gt_pig: $Id: avia_gt_pig.c,v 1.40 2003/09/30 05:45:35 obi Exp $
avia_gt_vbi: $Id: avia_gt_vbi.c,v 1.26 2003/08/01 17:31:22 obi Exp $
avia_gt_core: Loaded AViA eNX/GTX driver
Using /lib/modules/2.4.31-dbox2/misc/avia_gt_fb.o
avia_gt_fb: $Id: avia_gt_fb_core.c,v 1.54 2004/03/17 18:42:18 zwen Exp $
avia_gt_gv: set_input_mode (mode=2)
avia_gt_gv: set_input_size (width=720, height=576)
avia_gt_gv: set_input_mode (mode=2)
avia_gt_gv: set_input_size (width=720, height=576)
avia_gt_gv: set_input_mode (mode=2)
avia_gt_gv: set_input_size (width=720, height=576)
Console: switching to colour frame buffer device 82x32
avia_gt_fb: fb0: AViA eNX/GTX Framebuffer frame buffer device
Using /lib/modules/2.4.31-dbox2/misc/lcd.o
lcd.o: init lcd driver module
lcd.o: found KS0713/SED153X lcd interface
Using /lib/modules/2.4.31-dbox2/misc/avia_gt_lirc.o
avia_gt_lirc: $Id: avia_gt_lirc.c,v 1.14 2003/09/30 05:45:35 obi Exp $
avia_gt_ir: $Id: avia_gt_ir.c,v 1.30 2003/09/30 05:45:35 obi Exp $
Using /lib/modules/2.4.31-dbox2/misc/avia_gt_oss.o
avia_oss: $Id: avia_gt_oss.c,v 1.26 2004/05/31 22:56:02 carjay Exp $
avia_gt_pcm_set_rate(44100)
Using /lib/modules/2.4.31-dbox2/misc/avia_gt_v4l2.o
avia_gt_v4l2: $Id: avia_gt_v4l2.c,v 1.12 2003/09/30 04:54:03 obi Exp $
Using /lib/modules/2.4.31-dbox2/misc/ves1820.o
DVB: VES1820(0): pwm=0x48
DVB: registering frontend 0:0 (VES1820 based DVB-C frontend)...
Using /lib/modules/2.4.31-dbox2/misc/ves1x93.o
Using /lib/modules/2.4.31-dbox2/misc/avia_av_napi.o
avia_av_napi.c: $Id: avia_av_napi.c,v 1.33 2004/03/11 15:30:27 derget Exp $
Using /lib/modules/2.4.31-dbox2/misc/avia_gt_napi.o
avia_gt_napi: $Id: avia_gt_napi.c,v 1.203 2005/01/05 05:49:56 carjay Exp $
Using /lib/modules/2.4.31-dbox2/misc/dvb2eth.o
Using /lib/modules/2.4.31-dbox2/misc/aviaEXT_alt.o
Using /lib/modules/2.4.31-dbox2/misc/avia_gt_proc.o
avia_gt_proc: $Id: avia_gt_proc.c, v 0.1.3 2003/09/25 12:24:00 Skars & Merandos
Exp $
avia_gt_proc: Description: GTX/ENX proc_dev Driver with proc_fs extension
options:
(demux reinit) enx_reset=1
(framer chan.) fc_reset=0
(clr avia reg) avia=1
(enx td trace) trace=0
(lock, unlock) spinlock=0
Schreiben ueber avia_gt.o
(delay) delay=10
Starting pid 81, console /dev/console: '/etc/init.d/start'

Please press Enter to activate this console. boot-info is disabled
Setting Date...
Thu Jan 1 01:00:00 CET 1970
Starting sectionsd...
$Id: sectionsd.cpp,v 1.184 2005/05/02 19:06:35 rasc Exp $
caching 168 hours
events are old 60min after their end time
Starting timerd...
Starting Camd..
warte auf evocamd (max. 5 Sekunden)
evocamd erfolgreich gestartet
Starting zapit...
$Id: zapit.cpp,v 1.371 2005/04/17 06:56:15 metallica Exp $
Couldn't open config file: /var/keys/newcamd-client.txt
============================================================
(compiled Oct 21 2005 21:11:30)
styled by TBT Team, Next Level version 1.01(dream-dbox2-Triple Dragon)
============================================================
[evocamd] Process id 187
[camd] CA_SEND_MSG: Remote I/O error
/var/tuxbox/config/zapit/antiservices.xml: No such file or directory
/var/tuxbox/config/zapit/myservices.xml: No such file or directory
Starting controld...
$Id: controld.cpp,v 1.117 2004/05/22 14:34:09 carjay Exp $

[controld] Boxtype detected: (1, Nokia D-BOX2)
Starting nhttpd...
[controld] setting VideoFormat to auto
[nhttpd] Neutrino HTTP-Server starting..
[LCDFONT] initializing core...Starting neutrino...

[LCDFONT] adding font /share/fonts/micron.ttf...OK (Micron/Regular)
[LCDFONT] adding font /share/fonts/micron_bold.ttf...OK (Micron/Bold)
[LCDFONT] adding font /share/fonts/pakenham.ttf...OK (Pakenham/Regular)
[LCDFONT] Intializing font cache...
[neutrino] frameBuffer Instance created
812k video mem
avia_gt_gv: set_input_mode (mode=2)
avia_gt_gv: set_input_size (width=720, height=576)
[neutrino] Software update enabled
[neutrino] enable flash
[english.locale] missing entry: flashupdate.proxypassword_hint2
[english.locale] superfluous entry: fontsize.imageinfo_info
[english.locale] superfluous entry: fontsize.imageinfo_small
[english.locale] superfluous entry: imageinfo.creator
[english.locale] superfluous entry: imageinfo.date
[english.locale] superfluous entry: imageinfo.dokumentation
[english.locale] superfluous entry: imageinfo.forum
[english.locale] superfluous entry: imageinfo.head
[english.locale] superfluous entry: imageinfo.homepage
[english.locale] superfluous entry: imageinfo.image
[english.locale] superfluous entry: imageinfo.license
[english.locale] superfluous entry: imageinfo.version
[english.locale] superfluous entry: miscsettings.tuxtxt_cache
[english.locale] missing entry: movieplayer.bookmarkname_hint2
[english.locale] superfluous entry: servicemenu.imageinfo
[english.locale] superfluous entry: servicemenu.restart
[english.locale] superfluous entry: servicemenu.restart_failed
[english.locale] superfluous entry: servicemenu.restart_hint
[english.locale] superfluous entry: servicemenu.restart_refused_recording
[english.locale] superfluous entry: shutdown.recoding_query
[lcdd] time-skin not found -> using default...
[lcdd] weekday-skin not found -> using default...
[lcdd] date-skin not found -> using default...
[lcdd] month-skin not found -> using default...
[LCDFONT] initializing core...
[LCDFONT] adding font /share/fonts/12.pcf.gz...OK (Fix12/Regular)
[LCDFONT] adding font /share/fonts/14B.pcf.gz...OK (Fix14/Bold)
[LCDFONT] adding font /share/fonts/15B.pcf.gz...OK (Fix15/Bold)
[LCDFONT] Intializing font cache...
[LCDFONT] FTC_Face_Requester (Fix15/Bold)
[LCDFONT] FTC_Face_Requester (Fix14/Bold)
/dev/input/event1: No such file or directory
[neutrino] menue setup
[controld] setting VideoFormat to auto
loading locales: scandir: No such file or directory
[neutrino] registering as event client
[controld] setting VideoFormat to auto
[neutrino] initialized everything
zap failed!
[sectionsd] getUTC: read: Connection timed out
[sectionsd] getUTC: read: Connection timed out
[sectionsd] getUTC: read: Connection timed out
[sectionsd] getUTC: read: Connection timed out
[sectionsd] getUTC: read: Connection timed out
[sectionsd] getUTC: read: Connection timed out
[sectionsd] getUTC: read: Connection timed out
[sectionsd] getUTC: read: Connection timed out
 

mgb

Inactive User
Joined
May 9, 2005
Messages
3,939
Likes
29
#20
[camd] CA_SEND_MSG: Remote I/O error
That message looks not so good.
If you are lucky the file cam-alpha.bin is corrupt. I you are unlucky the SEC chip is faulty.
Do a ucode check in the service menue.
 
TEST
Top