Jtagging sammy - please help

player11

Inactive User
Joined
Mar 26, 2005
Messages
31
Likes
0
#1
Hi,
I've tried jtagging my new sammy but seemed to be getting nowhere.

I'm using the files supplied with the tutorial at the start of this page.
I've connected my jtag directly into my LPT1 port and the other end onto the J1202 on the board using the TMC universal pin adapter.

Everytime I try connecting to the sammy after enabling the eng mode I get error 43. Is there a resolution for this, or am I missing something?

I've tried searching for BK v2.2 and OCD to try a different method but cannot find these programs anywhere. Where are they?

I've also noticed my Net ID has now set at 09999. How do I insert the correct ID for my area?


Any help would be most appreciated.
 

player11

Inactive User
Joined
Mar 26, 2005
Messages
31
Likes
0
#2
I've managed to locate BKE v2.2 but still getting inernal error 43, also managed to get hold of OCD commander which won't run because it says I have old drivers. I read somewhere that I probably don't have it setup correctly, does anyone know how to configure this thing, again I can't find this anywhere.

Also is it normal when trying to read via jtag you should:
1) power up the sammy with no cable feed
2) wait till the display reads L20 and then depress the down key on the panel untill it gets to L40

Did all that and the box simply tries to restart and i'm left with a standard message saying your smartcard has been removed, also the front display is now reading 0
Its got the pink menu screen, does that mean I've probably got CR3.2, how can I verfy this?
Does this mean the jtag would not be able to connect to the unit whilst in this state?

Help....any guidence at this point would be very helpfull
 

exoticasian30

Inactive User
Joined
May 31, 2005
Messages
573
Likes
0
#3
player11 said:
I've managed to locate BKE v2.2 but still getting inernal error 43, also managed to get hold of OCD commander which won't run because it says I have old drivers. I read somewhere that I probably don't have it setup correctly, does anyone know how to configure this thing, again I can't find this anywhere.
Also is it normal when trying to read via jtag you should:
1) power up the sammy with no cable feed
2) wait till the display reads L20 and then depress the down key on the panel untill it gets to L40
Did all that and the box simply tries to restart and i'm left with a standard message saying your smartcard has been removed, also the front display is now reading 0
Its got the pink menu screen, does that mean I've probably got CR3.2, how can I verfy this?
Does this mean the jtag would not be able to connect to the unit whilst in this state?
Help....any guidence at this point would be very helpfull
Pink menu screen means that the box is still on exc&w cr3 software.
Don't worry about that too much at this stage.

Once you get past the error 43 problem (Possibly a poor connection between the pin adapter and the mainboard?) you can extract your BK and then reset the net id to the one you need by using the jtag.

The box will then update to the latest software required for your area.
 

player11

Inactive User
Joined
Mar 26, 2005
Messages
31
Likes
0
#4
Thanks for the avice guys,

Your right I need to resolve the error 43 problem before I can proceed. I'll do some searches and let you all know how I get on when I get home from work.
 

Donnie Darko

Inactive User
Joined
Jul 6, 2005
Messages
5,361
Likes
32
#5
player11 said:
I've managed to locate BKE v2.2 but still getting inernal error 43, also managed to get hold of OCD commander which won't run because it says I have old drivers. I read somewhere that I probably don't have it setup correctly, does anyone know how to configure this thing, again I can't find this anywhere.
Also is it normal when trying to read via jtag you should:
1) power up the sammy with no cable feed
2) wait till the display reads L20 and then depress the down key on the panel untill it gets to L40
Did all that and the box simply tries to restart and i'm left with a standard message saying your smartcard has been removed, also the front display is now reading 0
Its got the pink menu screen, does that mean I've probably got CR3.2, how can I verfy this?
Does this mean the jtag would not be able to connect to the unit whilst in this state?
Help....any guidence at this point would be very helpfull

Check all your solder connections,the GND usually gives me most grief and error 43,just attach it to the outer metal casing of box ,works every time.
You are also booting the stb up in-correctly,which will give you error43 message try this
1.press the +/- buttons together
2. apply power(plug in)
3when you see ld20,let go and press the - button
4 when ld40 appears let go.
5 should now be in correct mode
6 run bke or ocd,connect dump keys.
 

player11

Inactive User
Joined
Mar 26, 2005
Messages
31
Likes
0
#6
Hi Guy’s

I managed to resolve my error43 issue simply by:

1) Using my PC instead of my IBM laptop to Jtag the Sammy
2) Entering the BIOS on my pc and changing the LPT1 advanced settings to “EPP+ECP”

After connecting everything SDT read the BK and IRD straight away.

Just a note*

The Interchangeable pogo jtag is great but remember you will have to work with one hand whilst holding the Jtag in position with the other. Prepare all your bits around you prior to starting, I learned the hard way.

So thanks for all you input guys especially exoticasian30 the info sent was exactly what I needed.

Fantastic site guy’s it can be frustrating sometimes but if you search hard enough and ask the right questions eventually you will find the answers.
 

exoticasian30

Inactive User
Joined
May 31, 2005
Messages
573
Likes
0
#7
Nice one m8.

Looks like you did it pretty easily.
 
TEST
Top