Corrupt database - recovery suggestions?

numericOverflow

New Member ++
Joined
Jan 3, 2019
Messages
7
Reaction score
2
I've got a house with a Lutron 8 series system (H8P-D48-120) which appears to be O/S Rev : 01.49.01 T7. I don't know the original installer, and I don't have much of any history on the system, other than it seems to be in working order right now.

I want to tweak a few things and explore the system. Before doing anything, I want to backup the current configuration database. I

RS232
I was able to connect to the processor via RS232 using illuminations v1.65 to download the database. Unfortunately, when I try to open the database, it is corrupt. I even looked at the raw DAT/zip file that it transfers, and opened it via 7-zip and confirmed that the zip file CRC is invalid, which confirms why illuminations software can't open the file because there are issues compressing/decompressing the original database file.

Illuminations connects to the processor at 115200 buad, and some places I've seen online seem to suggest that transfering at a slower baud rate might help transfer a non-corrupt file. I flipped the DIP switch #2 so that it should communicate at 9600 baud, but doesn't. I also ran set baud, but that requires a reboot to take effect, but I'm worried about doing so, rendering the whole system useless. [NOTE: See some of my RS232 command(s) and output(s) at bottom of this post]

FTP

I don't know the credentials, so can't really connect. I did try connecting using an anonymous connection, but I don't get any files and I think it's really not providing me access.

Telnet
I tried connecting via telnet, but I don't know the user/pass so haven't had much luck here yet. I tried the default credentials found with a bit of googling, but the username seems incorrect, as I never proceed onto the next step to enter the password, it just re-prompts me for the user and disconnects me after 3 incorrect tries.

Web Interface
I can connect to the web interface via regular browser, and a virtual control panel shows up. I can click the buttons and the system reacts just as if I were pushing the associated physical wall buttons. Unfortunately, I don't see a way to gain higher privlege access or download anything from web, seems like a read-only interface. Is there some trick/hidden URL where I can get privileged access?

Given all this back story, I have a couple questions:
  1. Any suggestions on how to extract the running, working database?
  2. If I reboot the system, will that mess up the current working state and cause the processor to load the corrupted DB that I got over RS232, essentially rendering the system useless?
  3. Any gotchas once I do successfully extract the DB, make changes, and then upload to processor (i.e. upgrading from v1.49 to from v1.65)?
Thanks in advance for any help or suggestions!

------


04:40:40 PM (Rx) L232>
04:40:42 PM (Tx) PROCADDR
04:40:42 PM (Rx) Processor Address : 01 in OS mode
04:40:42 PM (Rx) L232>

04:41:55 PM (Tx) NETSTAT,1
04:41:56 PM (Rx) Processor 01:
04:41:56 PM (Rx) L232> MAC Address: [[REDACTED]]
04:41:56 PM (Rx) IP Address : [[REDACTED]]
04:41:56 PM (Rx) Subnet Mask: [[REDACTED]]
04:41:56 PM (Rx) Gateway : [[REDACTED]]
04:41:56 PM (Rx) Telnet Port: 23
04:41:56 PM (Rx) FTP Port : 21
04:41:56 PM (Rx) HTTP Port : 80
04:41:56 PM (Rx) Buffer HWM = 00001
04:41:56 PM (Rx) Socket HWM = 00032
04:41:56 PM (Rx) Successful Tx = 73341
04:41:56 PM (Rx) Error Tx = 00000
04:41:56 PM (Rx) Successful Rx = 00000
04:41:56 PM (Rx) Error Rx = 00000
04:41:56 PM (Rx) Ping response: ENABLED
04:41:56 PM (Rx) End of network statistics

04:44:06 PM (Tx) OSREV
04:44:07 PM (Rx) Processor 01 O/S Rev : 01.49.01 T7
04:44:07 PM (Rx) L232>

04:44:27 PM (Tx) GETBAUD,1:3
04:44:28 PM (Rx) RS232 baud rate on port 01:03 is 115200
04:44:33 PM (Rx) L232>

04:44:42 PM (Tx) GETHAND
04:44:43 PM (Rx) RS232 handshaking on port 01:03 is Hardware Handshaking
04:44:43 PM (Rx) L232>
 
TEST
Top