Autobouquetsmaker incompatible versions: 2.8>2.9 error

silverdale

VIP Member
VIP Member
Joined
Aug 2, 2007
Messages
2,726
I have just installed openATV 6.1 and abm and when I go to update the config I get this error :-

incompatible versions: 2.8>2.9

any idea's ?
 

charlie senator

VIP Member
VIP Member
Premium Member
Joined
Nov 25, 2005
Messages
6,250
Have they brought out a new version? I thought 2.8 was the latest.
 

silverdale

VIP Member
VIP Member
Joined
Aug 2, 2007
Messages
2,726
I'm not sure I've checked in plugins after update and still 2.8 so I would imagine there's a .ipk due for release or it will be added to the plugins in openATV shortly. If you have 2.8 try and update your autobouquetsmaker 2.8 config , you will get this error message I mentioned
 

Ferret

Administrator
Staff member
Administrator
Joined
Apr 13, 2007
Messages
12,273
Latest github you dont need an ipk

Do this

FTP to the Autobouqetsmaker folder and rename it AB1 or somat dont delete it

Transfer over the attached and chmod it to 755 then rebooot

Done
 

silverdale

VIP Member
VIP Member
Joined
Aug 2, 2007
Messages
2,726
rename the Autobouquetsmaker folder to AB1 then transfer over AutoBouquetsMaker-master and rename that to AutoBouquetsmaker ?
 
Last edited:

Ferret

Administrator
Staff member
Administrator
Joined
Apr 13, 2007
Messages
12,273
Yes mate hold fire though although the above is the latest off github its not 2.9 just let me see if i can find that.
 

ricky8777

Premium Member
Premium Member
Joined
Mar 23, 2002
Messages
182
Guys
If you do update Autobouquetsmaker
Don't update the Script and rescan because it takes out the fixes
You have to wait for the new updated images for the full fixes to be done
 
Last edited:

Ferret

Administrator
Staff member
Administrator
Joined
Apr 13, 2007
Messages
12,273
Yep 2.9 seems to be just to roll back the changes 2.8 made on narrator problem.
 

smirnoff_rules

VIP Member
VIP Member
Joined
Dec 17, 2005
Messages
13,218
yea . have a saved bouquet from yesterday thats was better , just put that back on , will wait abit now ,
 

Abu Baniaz

VIP Member
VIP Member
Joined
Mar 30, 2008
Messages
6,187
The version/check was brought in to avoid user problems if they update the config files but other changes in images/ABM python files are required.

When the version was bumped 2.9, it was done for the following reasons:
1. Prevent people who already have the PID hacks from removing them.
2. There are other encryption identification changes in another python files. We plan to improve the provider files

New OE-A images from Sunday will have the workaround for the Virgin Audio issue as well as ABM updated on their plugin server.
 

hackmax

VIP Member
VIP Member
Joined
Feb 11, 2006
Messages
2,074
Yep 2.9 seems to be just to roll back the changes 2.8 made on narrator problem.
Which is correct because they should never have put them in - it was never an ABM issue.

ABM does a great job but it's better that it's kept clean of 'bodges' for other issues outside of it's control.
 

baisha

New Member ++
Joined
Oct 13, 2012
Messages
16
is it possible to just download a ipk file for it because i dont understand how to do all of these updates
 

Ferret

Administrator
Staff member
Administrator
Joined
Apr 13, 2007
Messages
12,273
is it possible to just download a ipk file for it because i dont understand how to do all of these updates
2.9 wont help you its just rolls back to before they fixed the issue with abm a dirty fix if you like images will be coming out from today patched properly to allow the correct audio options.
 

madman2401

New Member
Joined
Nov 19, 2017
Messages
3
I am also getting the incompatible version 2.8 > 2.9 error message so I can't scan channels.

Will there be an update to 2.9 under system plugins or will I need to delete and install 2.9 when it's available?
 
TEST
Top