1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ooops, broke my mate's TomTom

Discussion in 'General Chat' started by chookey, Jan 10, 2017.

  1. chookey

    chookey VIP Member VIP Member Premium Member

    Joined:
    Oct 6, 2005
    Messages:
    3,158
    Likes Received:
    88
    This is an old Go 520 which I probably last updated the map on about 4 years ago. He asked me to update it again, God only knows why cos his longest trip ever is to Coventry, 8 miles away :proud:

    I installed TomTom Home on my pc but probably stupidly installed a software update and now I get a map error.
    "You cannot use this map on this device"
    United_Kingdom_and_Republic_of_Ireland_665

    I can't get into the menu anymore, just this error. I tried restoring the backup but still get the error.
    Any advice greatly appreciated as always

    Okay, it appears that the installed map is no longer patched. The FastActivate.exe is dated 17.02.2013 so will need updating along with the map of course. I'm now trying to find which later maps are suitable for this model. Looks as though I need to join a gps forum. Really hate the idea of doing this just to get a download though, goes against the grain.
     
    Last edited: Jan 10, 2017
  2. lammy1961

    lammy1961 New Member

    Joined:
    Sep 27, 2010
    Messages:
    21
    Likes Received:
    0
    Make yourself a member of Navitotal, you will get sorted there.
     
  3. chookey

    chookey VIP Member VIP Member Premium Member

    Joined:
    Oct 6, 2005
    Messages:
    3,158
    Likes Received:
    88
    Thanks mate, had already joined another forum. Got the old map working again plus the latest map.
    Just trying to get my head round speedcams at the moment.
     

Share This Page