RNS510 screen flicker/turning off

majo72

Member
Joined
Nov 29, 2018
Messages
11
A couple of weeks ago, after shutting down the car but not open the door, the radio screen started to turn off and on. Not only the screen but the button background lightning on the device as well as the navigation part of the cluster computer. During the blackout and some after, the sound also muting.Everything else on the car works just fine.
Connected to the Bosch VAGCOM at my job and there were no stored error codes neither.
Tried to boot up with firmware update DVD to see if the problem temporarily disappeared during SW update but same problem there (Could pursue with the FW update but the screen shutter off several times and I had to press power button for it to lit up agin)
Opened up the unit and removed the Power Board to see if there were bad soldering but it looked just fine.
In test mode, all temperatures seemed normal.
HDD seemed normal.
Navigation works in background.
Unit's buttons background light shuts off with display.
Here's a video showing the issue.
https://www.youtube.com/watch?v=N-zn...ature=youtu.be


I really hope someone have an good idea how to fix this


By the way, it's a Passat 2011.
 

majo72

Member
Joined
Nov 29, 2018
Messages
11
I measured the incoming 12V while having it mounted in the car. The voltage as well as grounding was stable during the flicker, so perhaps the fault is internal?
 

filcorad

New Member
Joined
Jan 21, 2019
Messages
4
"Steering wheel is in the wrong place" :D;)

Thanks, I will have a look. It seems expensive to repair this units :oops:
did you solve the problem with this unit?
you must check the integrity for all pins of the connector from front (PCB with buttons&display)
also look for some corosion signs on this PCB
a magnifier is recomended
I "rescue" one unit last year ;)
 

majo72

Member
Joined
Nov 29, 2018
Messages
11
did you solve the problem with this unit?
you must check the integrity for all pins of the connector from front (PCB with buttons&display)
also look for some corosion signs on this PCB
a magnifier is recomended
I "rescue" one unit last year ;)
No, I didn't. I checked the pins and everything looked as new. In the end I decided to buy another unit on eBay. Got it for under 400 euro including shipment and that was a 2017 unit with SSD in mint condition. Now I've got the old one here in a box, not sure what to do with it yet. Perhaps sell it as a DIY unit, as soon I get the radio code for it :)
 

filcorad

New Member
Joined
Jan 21, 2019
Messages
4
No, I didn't. I checked the pins and everything looked as new. In the end I decided to buy another unit on eBay. Got it for under 400 euro including shipment and that was a 2017 unit with SSD in mint condition. Now I've got the old one here in a box, not sure what to do with it yet. Perhaps sell it as a DIY unit, as soon I get the radio code for it :)
Other cause can be the corossion of the trough holes from PCB
The code must be within the car papers. If not, must ask VW dealer from your town.
If still can't got the code, unit need to be decoded. Not easy thing for this model, but can be done :)
Good luck.
 
TEST
Top