stealth and extreme 5.2?

Colin

DW Member +
Joined
Nov 17, 2005
Messages
3,408
Likes
15
#1
Do you need to worry about wether or not a game is stealth patched if you have the latest sammy firmware?
 

i-zombie

VIP Member
VIP Member
Joined
Oct 22, 2005
Messages
3,744
Likes
49
#4
this is a misconception,stealth patches are not required to play online,they are merely added protection
 

Purity

VIP Member
VIP Member
Joined
Apr 9, 2006
Messages
4,088
Likes
59
#5
Sorry, I did mean "required" to protect yourself on Live, but not required to actually play online as violentj points out
 

djlive

Inactive User
Joined
Feb 12, 2007
Messages
7
Likes
0
#6
make sure its patched, better to be safe than sorry.
 
TEST
Top