Inactive User
Dec 19, 2006
Reaction score
Within 20 metres :)
ive got a 200gb in ma comp which is full so i decided to put another 300gb in. One of my friends had a 300gb lying around with some stuff on it so he decided to give it to me. Ive put the new HDD in and my computer picks it up fine but it doesnt display it in My Computer under Hard Disk Drives. MY question is is there anyway to get it to show there without having to reformat it. In disk management it shows up as a foreign disk drive.

Thanks in advance
if your running windows other than xp then its possible its an ntfs format drive, if so you will have to repartition it and reformat, that also applies if its non dos format too, apple etc.

what windows are you using.

And what windows was on the pc it came from.
in that case then the drive isnt connected correctly.

couple things to check (make sure you turn off pc)

1. Jumper settings on slave drive - set to slave or cable select.

2. If on a new high density cable blue end into mainboard, end grey connector to master drive, middle grey connector to slave drive.
in any case master is at end and slave in middle.

3. Check in bios secondary drive is enabled, they are sometimes disabled to speed up booting. press the del key on powerup of pc.
ive sorted it out. used the windows help and sorted it out. it was showing as a foreign disk in disk management so i just imported the foreign disk and now it accessable.

Thanks for your reply m8. it seemed that it was used as a dynamic disk by my friend so i just imported it and seem to be fine.