Xbox 360 Trinity RGH Bricked?


Member ++
Mar 27, 2005
Reaction score
Hi Guys,
I have a Trinity RGH2 that I tried to put the kinect update on last week using JRunner. Console was on 17349 and I tried to use JRunner to update to 17526. I turned the updserv option on in dashlaunch and JRunner found and updated the console via command prompt. Unfortunately, after the update, all I got was a Red dot in the middle of the console. The console does boot to Xell.
Any ideas of anything I can try to get it back? Unfortunately, I don't have the original nand backed up (I know...dumb). Can someone help???!!!!

Any advice appreciated


Log file from patch below with Keys omitted:
xeBuild v1.18.800
---- { Update Mode } ----
data directory set from command line to '17511\'
started, watching network for xbox...success, found xbox beacon at
attempting to connect...success!
Getting console info...success!
connected to Trinity with updsvr version 3 (peek version 2)
NAND image size: 0x1080000 Block size: 0x4200 Spare Data: Yes
------ parsing console info response ------
Console Current Info:
running kernel : 2.0.17349.0
bootstrap type : Trinity
hardware type : Trinity
hardware flags : 0x40000207
internal HDD : not present
Image Type : Trinity (Glitch2)
------ parsing ini at '17511\_glitch2.ini' ------
ini version 17511
ini: label [trinitybl] found
found (1) 'cba_9188.bin' crc: 0x5a76752d
found (2) 'cbb_9188.bin' crc: 0xfebb1074
found (3) 'cd_9452.bin' crc: 0x455fa02c
found (4) 'ce_1888.bin' crc: 0xff9b60df
found (5) 'cf_17511.bin' crc: 0x24e035b7
found (6) 'cg_17511.bin' crc: 0x8770cc26
ini dictates dual CB for this model
[rawpatch] label not found in ini
ini: label [flashfs] found
found (1) 'aac.xexp' crc: 0x1103da68
found (2) 'bootanim.xex' crc: 0x880a3f4e
found (3) 'createprofile.xex' crc: 0x612b43b7
found (4) 'dash.xex' crc: 0x8eff9b2a
found (5) 'deviceselector.xex' crc: 0x80d3d38d
found (6) 'gamerprofile.xex' crc: 0x5df2195f
found (7) 'hud.xex' crc: 0xfcb1a86a
found (8) 'huduiskin.xex' crc: 0xf19a8107
found (9) 'mfgbootlauncher.xex' crc: 0x1cef3835
found (10) 'minimediaplayer.xex' crc: 0x41007364
found (11) 'nomni.xexp' crc: 0xb882b4c0
found (12) 'nomnifwk.xexp' crc: 0x60cddde5
found (13) 'nomnifwm.xexp' crc: 0x0590880a
found (14) 'SegoeXbox-Light.xtt' crc: 0xe0ee6049
found (15) 'signin.xex' crc: 0xfbcfdb28
found (16) 'updater.xex' crc: 0x3de84a4f
found (17) 'vk.xex' crc: 0xbe21f601
found (18) 'xam.xex' crc: 0x40c9ff03
found (19) 'xenonclatin.xtt' crc: 0xd5d17ff5
found (20) 'xenonclatin.xttp' crc: 0x7a507ad1
found (21) 'xenonjklatin.xtt' crc: 0xdde4a14c
found (22) 'xenonjklatin.xttp' crc: 0xe2adddfb
found (23) 'ximecore.xex' crc: 0x173eb4ff
found (24) 'ximedic.xex' crc: 0x1d992bfb
found (25) 'ximedic.xexp' crc: 0xc68df8c2
found (26) '..\launch.xex' crc: 0x00000000
found (27) '..\lhelper.xex' crc: 0x00000000
found (28) '..\launch.ini' crc: 0x00000000
found (29) '..\launch.xex' crc: 0x00000000
found (30) '..\lhelper.xex' crc: 0x00000000
found (31) '..\launch.ini' crc: 0x00000000
ini: label [security] found
found (1) 'crl.bin' crc: 0x00000000
found (2) 'dae.bin' crc: 0x00000000
found (3) 'extended.bin' crc: 0x00000000
found (4) 'fcrt.bin' crc: 0x00000000
found (5) 'secdata.bin' crc: 0x00000000
------ ini parsing completed ------

------ getting bad blocks ------
no bad blocks found on device
mounting \SystemRoot to usv:...success!
------ getting bootloaders ------
reading bootloader data...success! Bootloader size with xell is 0x000b0000
------ getting security files ------
retrieving USVR\crl.bin...OK, received 0xa00 bytes
sig good! verified! Will use if external file not found.
retrieving USVR\dae.bin...OK, received 0xad30 bytes
sig 1 good! sig 2 good! verified! Will use if external file not found.
retrieving USVR\extended.bin...OK, received 0x4000 bytes
verified! Will use if external file not found.
retrieving USVR\fcrt.bin...OK, received 0x4000 bytes
sig good! verified! Will use if external file not found.
retrieving USVR\secdata.bin...OK, received 0x400 bytes
verified! Will use if external file not found.
extracting BLDR\kv_enc...OK, received 0x4000 bytes
decrypt and verify...keyvault is good!
extracting BLDR\smc_enc...OK, received 0x3000 bytes
decrypt and verify...smc is good!
------ getting mobile settings ------
retrieving USVR\MobileB.dat...OK, received 0x800 bytes
retrieving USVR\MobileC.dat...OK, received 0x200 bytes
retrieving USVR\MobileD.dat...OK, received 0x800 bytes
retrieving USVR\MobileE.dat...OK, received 0x800 bytes
retrieving USVR\MobileF.dat...not available
retrieving USVR\MobileG.dat...not available
retrieving USVR\MobileH.dat...not available
retrieving USVR\MobileI.dat...not available
retrieving USVR\MobileJ.dat...not available
retrieving USVR\Statistics.settings...OK, received 0x400 bytes
retrieving USVR\, received 0x80 bytes
console has no available blmod
retrieving USVR\addons...OK, received 0xc bytes
addon patch from console: nohdmiwait
retrieving USVR\Static.settings (smc_config.bin)...OK, received 0x4000 bytes
verifying...smc_config is good!
------ Copying bootloader image to flash image ------
CB v9188 at 0x8000 size 0x1ac0 (CB)
CB v9188 at 0x9ac0 size 0x7800 (dual CB)
CD v9452 at 0x112c0 size 0x5290 (CD)
CE v1888 at 0x16550 size 0x5606a (CE)
final truncated bootloader size 0x6c5c0
------ loading system update container ------
17511\su20076000_00000000 found, loading...done!
Read 0xb52000 bytes to memory
checking integrity...
header seems valid, version 2.0.17511.0
header hash is OK, checking content hashes...
content hashes seem OK, everything looks good!
extracted SUPD/xboxupd.bin (0x7ca80 bytes)
decrypting SUPD/xboxupd.bin/CF_17511.bin (0x4560 bytes)...done!
decrypting SUPD/xboxupd.bin/CG_17511.bin (0x7851e bytes)...done!
------ Loading bootloaders and required security files ------
using smc binary from console
reset smc load address to 0x1000 size 0x3000
using keyvault data from console
skipping cba_9188.bin as it is in glitch bootloader dump
skipping cbb_9188.bin as it is in glitch bootloader dump
skipping cd_9452.bin as it is in glitch bootloader dump
skipping ce_1888.bin as it is in glitch bootloader dump
xell not found in perbuild directory, checking firmware /bin folder
xell not found in firmware /bin folder, checking base path
reading xell-gggggg.bin (0x40000 bytes)
extracted SUPD/xboxupd.bin/CF_17511.bin (0x4560 bytes)
extracted SUPD/xboxupd.bin/CG_17511.bin (0x7851e bytes)
reading 17511\bin\patches_g2trinity.bin (0x91c bytes)
reading 17511\bin\nohdmiwait.bin (0xc bytes)
added 0xc bytes to patches via 1 external patch files
patches now 0x92c bytes total with addon byte count appended
using smc configuration from console
checking smc_config
extracting config
SMC config info:
Target temps: Cpu: 82øC Gpu: 78øC Edram: 76øC
Max temps : Cpu: 89øC Gpu: 82øC Edram: 82øC
Cpu Fan : (auto)
Gpu Fan : (auto)
MAC Address :
AVRegion : 0x00000300 (PAL50)
GameRegion : 0x02fe (PAL/EU)
DVDRegion : 2
resetKey : YARY
Checking for smc config data patches
smc config was not patched
patch slot offset reset to: 0xb0000
------ Patching BLs and modifying patches ------
Fixing up patch set...Done!
------ Encrypting and finalizing bootloaders ------
encoding cf_17511.bin size 0x4560
encoding cg_17511.bin size 0x78520
------ Adding bootloaders to flash image ------
adding xell-gggggg.bin at raw offset 0x00070000 len 0x40000 (end 0xb0000)
adding cf_17511.bin at raw offset 0x000b0000 len 0x4560 (end 0xb4560)
adding cg_17511.bin at raw offset 0x000b4560 len 0x78520 (end 0xc0000, rest in fs)
adding patches_g2trinity.bin at raw offset 0x000c0010 len 0x55c (end 0xc056c)
Fixing up FS table...done!
Writing zeropair CG patch slot overflow data to sysupdate.xexp1
at raw offset 0xd0000 len 0x0006ca80 (end: 0x0013ca80)...done!
------ adding 31 firmware files ------
extracted SUPD/aac.xexp (0x14000 bytes) (crc32: 0x1103da68 ini: 0x1103da68)
adding as aac.xexp1 at raw offset 0x13ca80 len 0x00014000 (end 0x00150a80)
extracted SUPD/bootanim.xex (0x61000 bytes) (crc32: 0x880a3f4e ini: 0x880a3f4e)
adding as bootanim.xex at raw offset 0x154000 len 0x00061000 (end 0x001b5000)
extracted SUPD/createprofile.xex (0xc000 bytes) (crc32: 0x612b43b7 ini: 0x612b43b7)
adding as createprofile.xex at raw offset 0x1b5000 len 0x0000c000 (end 0x001c1000)
extracted SUPD/dash.xex (0x5b2000 bytes) (crc32: 0x8eff9b2a ini: 0x8eff9b2a)
adding as dash.xex at raw offset 0x1c4000 len 0x005b2000 (end 0x00776000)
extracted SUPD/deviceselector.xex (0xa000 bytes) (crc32: 0x80d3d38d ini: 0x80d3d38d)
adding as deviceselector.xex at raw offset 0x776000 len 0x0000a000 (end 0x00780000)
extracted SUPD/gamerprofile.xex (0x1b000 bytes) (crc32: 0x5df2195f ini: 0x5df2195f)
adding as gamerprofile.xex at raw offset 0x782000 len 0x0001b000 (end 0x0079d000)
extracted SUPD/hud.xex (0x1d000 bytes) (crc32: 0xfcb1a86a ini: 0xfcb1a86a)
adding as hud.xex at raw offset 0x79f000 len 0x0001d000 (end 0x007bc000)
extracted SUPD/huduiskin.xex (0x14000 bytes) (crc32: 0xf19a8107 ini: 0xf19a8107)
adding as huduiskin.xex at raw offset 0x7bd000 len 0x00014000 (end 0x007d1000)
extracted SUPD/mfgbootlauncher.xex (0x8000 bytes) (crc32: 0x1cef3835 ini: 0x1cef3835)
adding as mfgbootlauncher.xex at raw offset 0x7d4000 len 0x00008000 (end 0x007dc000)
extracted SUPD/minimediaplayer.xex (0xc000 bytes) (crc32: 0x41007364 ini: 0x41007364)
adding as minimediaplayer.xex at raw offset 0x7dc000 len 0x0000c000 (end 0x007e8000)
extracted SUPD/nomni.xexp (0xf000 bytes) (crc32: 0xb882b4c0 ini: 0xb882b4c0)
adding as nomni.xexp1 at raw offset 0x7e8000 len 0x0000f000 (end 0x007f7000)
extracted SUPD/nomnifwk.xexp (0x2000 bytes) (crc32: 0x60cddde5 ini: 0x60cddde5)
adding as nomnifwk.xexp1 at raw offset 0x7f7000 len 0x00002000 (end 0x007f9000)
extracted SUPD/nomnifwm.xexp (0x5000 bytes) (crc32: 0x0590880a ini: 0x0590880a)
adding as nomnifwm.xexp1 at raw offset 0x7fa000 len 0x00005000 (end 0x007ff000)
extracted SUPD/SegoeXbox-Light.xtt (0x6000 bytes) (crc32: 0xe0ee6049 ini: 0xe0ee6049)
adding as SegoeXbox-Light.xtt at raw offset 0x801000 len 0x00006000 (end 0x00807000)
extracted SUPD/signin.xex (0x1a000 bytes) (crc32: 0xfbcfdb28 ini: 0xfbcfdb28)
adding as signin.xex at raw offset 0x80a000 len 0x0001a000 (end 0x00824000)
extracted SUPD/updater.xex (0x7000 bytes) (crc32: 0x3de84a4f ini: 0x3de84a4f)
adding as updater.xex at raw offset 0x826000 len 0x00007000 (end 0x0082d000)
extracted SUPD/vk.xex (0xb000 bytes) (crc32: 0xbe21f601 ini: 0xbe21f601)
adding as vk.xex at raw offset 0x82f000 len 0x0000b000 (end 0x0083a000)
extracted SUPD/xam.xex (0x251000 bytes) (crc32: 0x40c9ff03 ini: 0x40c9ff03)
adding as xam.xex at raw offset 0x83b000 len 0x00251000 (end 0x00a8c000)
retrieving USVR\xenonclatin.xtt...OK, received 0x11b000 bytes
extracted USVR/xenonclatin.xtt (0x11b000 bytes) (crc32: 0xd5d17ff5 ini: 0xd5d17ff5)
adding as xenonclatin.xtt at raw offset 0xa8d000 len 0x0011b000 (end 0x00ba8000)
extracted SUPD/xenonclatin.xttp (0x18000 bytes) (crc32: 0x7a507ad1 ini: 0x7a507ad1)
adding as xenonclatin.xttp1 at raw offset 0xbab000 len 0x00018000 (end 0x00bc3000)
retrieving USVR\xenonjklatin.xtt...OK, received 0x1a8000 bytes
extracted USVR/xenonjklatin.xtt (0x1a8000 bytes) (crc32: 0xdde4a14c ini: 0xdde4a14c)
adding as xenonjklatin.xtt at raw offset 0xbc4000 len 0x001a8000 (end 0x00d6c000)
extracted SUPD/xenonjklatin.xttp (0x7000 bytes) (crc32: 0xe2adddfb ini: 0xe2adddfb)
adding as xenonjklatin.xttp1 at raw offset 0xd6c000 len 0x00007000 (end 0x00d73000)
extracted SUPD/ximecore.xex (0x17000 bytes) (crc32: 0x173eb4ff ini: 0x173eb4ff)
adding as ximecore.xex at raw offset 0xd73000 len 0x00017000 (end 0x00d8a000)
retrieving USVR\ximedic.xex...OK, received 0x90000 bytes
extracted USVR/ximedic.xex (0x90000 bytes) (crc32: 0x1d992bfb ini: 0x1d992bfb)
adding as ximedic.xex at raw offset 0xd8b000 len 0x00090000 (end 0x00e1b000)
extracted SUPD/ximedic.xexp (0x2800 bytes) (crc32: 0xc68df8c2 ini: 0xc68df8c2)
adding as ximedic.xexp1 at raw offset 0xe1c000 len 0x00002800 (end 0x00e1e800)
reading 17511\..\launch.xex (0xb800 bytes)
adding as launch.xex at raw offset 0xe1e800 len 0x0000b800 (end 0x00e2a000)
reading 17511\..\lhelper.xex (0x4800 bytes)
adding as lhelper.xex at raw offset 0xe2b800 len 0x00004800 (end 0x00e30000)
reading 17511\..\launch.ini (0x20a bytes)
adding as launch.ini at raw offset 0xe30800 len 0x0000020a (end 0x00e30a0a)
reading 17511\..\launch.xex (0xb800 bytes)
adding as launch.xex at raw offset 0xe3420a len 0x0000b800 (end 0x00e3fa0a)
reading 17511\..\lhelper.xex (0x4800 bytes)
adding as lhelper.xex at raw offset 0xe43800 len 0x00004800 (end 0x00e48000)
reading 17511\..\launch.ini (0x20a bytes)
adding as launch.ini at raw offset 0xe48800 len 0x0000020a (end 0x00e48a0a)
------ adding 5 security files ------
<- Processing crl.bin ->
could not read crl.bin, using data from SUPD...
crl appears crypted, attempting to decrypt with CPU key...failed! Trying alternate key...sig good! success!
adding as crl.bin at raw offset 0xe50000 len 0x00000a00 (end 0x00e50a00)
<- Processing dae.bin ->
could not read dae.bin, using data from SUPD...
dae appears encrypted, attempting to decrypt with CPU key...failed! Attempting to decrypt with alternate key...
adding as dae.bin at raw offset 0xe54000 len 0x00007090 (end 0x00e5b090)
<- Processing extended.bin ->
could not read extended.bin, using data from previous parse...
adding as extended.bin at raw offset 0xe5c000 len 0x00004000 (end 0x00e60000)
<- Processing fcrt.bin ->
could not read fcrt.bin, using data from previous parse...
adding as fcrt.bin at raw offset 0xe60000 len 0x00004000 (end 0x00e64000)
<- Processing secdata.bin ->
could not read secdata.bin, using data from previous parse...
adding as secdata.bin at raw offset 0xe64000 len 0x00000400 (end 0x00e64400)
------ checking for Mobile*.dat ------
MobileB.dat found, adding from previous parse
adding MobileB.dat as type 0x31 at raw offset 0xe68000 len 0x800 (end 0xe68800)
MobileC.dat found, adding from previous parse
adding MobileC.dat as type 0x32 at raw offset 0xe6c000 len 0x200 (end 0xe6c200)
MobileD.dat found, adding from previous parse
adding MobileD.dat as type 0x33 at raw offset 0xe70000 len 0x800 (end 0xe70800)
MobileE.dat found, adding from previous parse
adding MobileE.dat as type 0x34 at raw offset 0xe74000 len 0x800 (end 0xe74800)
Statistics.settings found, adding from previous parse
adding Statistics.settings at raw offset 0xf78000 len 0x400 (end 0xf78400) found, adding from previous parse
adding at raw offset 0xf74000 len 0x80 (end 0xf74080)
------ adding smc_config.bin ------
adding smc config to offset 0x00f7c000, len 0x400
------ cleaning up image ------
Fixing up empty FS block entries...done!
Writing FS table to image offset 0xe78000 len 0x4000 (end 0xe7c000)...done!
------ finalizing image ------
fixing up big block controller on small block NAND LBA numbers...done!
calculating ECD bytes and assembling raw image...done!
done remapping!
unmounting usv:...success!
------ flashing console ------
sending flash data to console...
file sent OK, awaiting result...success!
Completed in 6s
------ loading and sending avatar data ------
avatar data skipped, no HDD detected
sending reboot command...OK
17511_g2_trinity.bin image built, info:
Kernel : 2.0.17511.0
Console : Trinity
NAND size : 16MiB
Build : Glitch (v2)
Xell : power on console with console eject button


Staff member
May 2, 2005
Reaction score
The Moon
Is the xbox 360 a slim one ?

do you know your drive key ?

found this worth a shot

donor trinity NAND

This is for a slim Trinity

Get it here
Last edited: