Toshiba L350 , SATA drivers please help

silverdale

VIP Member
VIP Member
Joined
Aug 2, 2007
Messages
4,540
Reaction score
3,982
im having to fit a new Harddrive to my laptop but i cant get to work as the laptop uses a SATA HD and needs SATA drivers but the laptop doesnt have a floppy drive.
so i followed a guide using Nlite:-

Install Windows XP on SATA without a Floppy (F6) - No Floppy...no Windows on SATA? Wrong! - Softpedia

but after making a new installation XP CD by following the guide to the letter the laptop still doesnt pick up the new HD.
can someone please tell me what are the correct drivers for a samsung HM160HI harddrive ?.
also , do i hit F6 when loading XP or should it automatically pick up the HD once i've made a new disc using Nlite ?.
 

little_pob

VIP Member
VIP Member
Joined
Dec 10, 2004
Messages
8,769
Reaction score
2,477
Location
mmm....padded walls....so soft...
Which drivers did you use? Try following the instructions in the second paragraph on this site: _http://www.microtext.co.uk/Toshiba-Satellite-L350-170-XP-Install.html

Have you tried changing the SATA controller mode in the BIOS? NB this may impact on the speed performance of the drive.
 
Last edited:

silverdale

VIP Member
VIP Member
Joined
Aug 2, 2007
Messages
4,540
Reaction score
3,982
if i change the sata controller it reverts to the old slow mode which i dont think is the way.
can someone please tell me (or a link would be handy) what are the correct SATA drivers for a "samsung HM160HI hard drive" ?.
surely using nlite is the simplest answer.i,ve already added iaahci.inf - iastor.inf - and even si3112 to an XP installation CD but even though XP loads the Drivers it still says at the end " no hard drive can be detected.............".
 

ManofScience

VIP Member
VIP Member
Joined
Jun 4, 2007
Messages
4,045
Reaction score
525
you only need it in legacy IDE (or slow mode as you call it) for the installer to work. Once it's done, change it back.
 

ManofScience

VIP Member
VIP Member
Joined
Jun 4, 2007
Messages
4,045
Reaction score
525
u need xp with service pack 3 intergrated then it will work

hhmm... you must be right. we had a range of hp dx5150 towers that were all set to SATA raid, setting to IDE legacy would always then let XP SP3 install disk work. never tried it with anything earlier than that...

if we did, we'd extract the SATA drivers from the driver pack and install them from a floppy.

you should be able to extract them from here : http://support1.toshiba-tro.de/tedd-files2/0/stormng-20080908151852.ZIP but i guess u have already
 
Last edited:
TEST
Top