• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

RROD Oh dear!

wozzo

Inactive User
Joined
Dec 30, 2006
Messages
1,777
Likes
66
#1
Well after me bragging about how my 1st gen 360 has never failed in a previous thread last week, it looks like if jinxed myself and its started to red ring.


Sometimes when i turn it on it red rings but if i simply switch it of and back on it works.


Is this the early sign of total meltdown?



And why does now make a wierds sound at startup?
 

fishy123

Inactive User
Joined
Mar 23, 2005
Messages
592
Likes
6
#2
its on its way out affraid :(
those are the symptoms mine had (including the weird sounds) before it went completely a few days later.
 

2primo

Inactive User
Joined
Mar 27, 2005
Messages
597
Likes
12
#3
its a diy repair or the poss of a lite-on drive for you mine went a few days ago and its @ MS now for repair
i have a spare so its no fuss to me if it comes back a lite-on its going on ebay and i will buy a new one i wtd the hdmi port ne way as i use it as a media center ....
Good luck with your choice !!
 

showders

Inactive User
Joined
Feb 14, 2006
Messages
552
Likes
6
#4
its a diy repair or the poss of a lite-on drive for you mine went a few days ago and its @ MS now for repair
i have a spare so its no fuss to me if it comes back a lite-on its going on ebay and i will buy a new one i wtd the hdmi port ne way as i use it as a media center ....
Good luck with your choice !!

Do you find yours too noisy when watching normal TV? If so, have you managed to make it any quieter?

Cheers
 

wozzo

Inactive User
Joined
Dec 30, 2006
Messages
1,777
Likes
66
#5
Opened it up and gave the heatsink a cleaning, working so far.



Have the X-clamp fix on the way, anyone found it good?
 

mike361

VIP Member
VIP Member
Joined
May 7, 2007
Messages
971
Likes
9
#6
i`v fitted 4 with the kit and its been all good up to now thats been a few months too