• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

psp ic1003 help

Nightcrawler1

Inactive User
Joined
Dec 15, 2006
Messages
149
Likes
0
#1
guy i have look around digiworldz and am a wee bit confused so can some one point me in the right direction so i dont brick her psp thats only a month old so i would like a step by step tut (idot proof of course lol) and does it mean if i do it right she can play games that i can download .... from her 4 gig memory card .....thank you
 

Kryton

<font color="PINK">I LOVE PINK</font>
VIP Member
Joined
Jan 31, 2006
Messages
2,919
Likes
170
#2
whats the current firmware version on it at the moment?

if the firmware is 3.03 or under then it can be done and yes she will be able to play downloaded games. but before you can be pointed in the right direction the current FW version is needed.
 
Last edited:

edds

VIP Member
VIP Member
Joined
Mar 5, 2005
Messages
1,509
Likes
30
#3
If above 2.71 and below 3.03, upgrade to 3.03 and then downgrade to 1.50 using an unpatched copy of Grand Theft Auto Liberty City Stories.

If below 2.71; up it to 2.71 and use this (no need for GTA:LCS). If exactly 2.71 then ignore the up it to 2.71, lol. _http://pspupdates.qj.net/index.php?pg=49&aid=77460

Kryton's post here for 3.03 http://www.digitalworldz.co.uk/forums/showthread.php?t=117480 helps

If all runs well, then yes you can run games from the card, I did a TA-082 (IC1003) 2.81 for my daughter, upped to 3.03, down to 1.50 and back up to 3.10OE. Remember, though the chances of bricking it are not yet 0%.
 

Kryton

<font color="PINK">I LOVE PINK</font>
VIP Member
Joined
Jan 31, 2006
Messages
2,919
Likes
170
#4
yeah except you can downgrade from 2.80 without the need for GTA:lcs.

anything above 2.80 to 3.03 you do need it.

if it's brand spanking new from the shop though and only a month old then i would guess it is over 2.80 anyway.
 
Last edited:

edds

VIP Member
VIP Member
Joined
Mar 5, 2005
Messages
1,509
Likes
30
#5
yeah except you can downgrade from 2.80 without the need for GTA:lcs.

anything above 2.80 to 3.03 you do need it.

if it's brand spanking new from the shop though and only a month old then i would guess it is over 2.80 anyway.
Yeah sorry kryton, forgot about this one for 2.80 and below _http://dl.qj.net/TA-082-Easy-Downgrader-PSP/pg/12/fid/12267/catid/114
 

Nightcrawler1

Inactive User
Joined
Dec 15, 2006
Messages
149
Likes
0
#6
yeah its brand new from a shop .........it says system software version 2.81

and before i go ahead with it if i mess it up would the shop know if i took it back saying it stopped working also do i have to buy this unpatched copy of Grand Theft Auto Liberty City Stories
 
Last edited:

DoomedEarl

VIP Member
VIP Member
Joined
Oct 4, 2005
Messages
1,863
Likes
28
#7
yeah its brand new from a shop .........it says system software version 2.81

and before i go ahead with it if i mess it up would the shop know if i took it back saying it stopped working
Doubt it... it wouldn't work, you haven't opened it up. Still under warranty... but don't be so pessimistic!!!

also do i have to buy this unpatched copy of Grand Theft Auto Liberty City Stories
You will need an unpatched copy of GTA:LCS.
If you follow the instructions using the Noobz downgrader then you should be fine. Loads of us on here have done it without problems.

http://www.digitalworldz.co.uk/forums/index.php?resources/1027/
 
Last edited by a moderator:

Nightcrawler1

Inactive User
Joined
Dec 15, 2006
Messages
149
Likes
0
#9
If above 2.71 and below 3.03, upgrade to 3.03 and then downgrade to 1.50 using an unpatched copy of Grand Theft Auto Liberty City Stories

my question is wer can i get unpatched copy of Grand Theft Auto Liberty City Stories or can anyone sell me a copy thats on a disk
 

DEE747

DW Member +
Joined
Nov 22, 2005
Messages
1,526
Likes
12
#10
post ur location m8 if a member lives nr you he mite be able to save u sum cash by loaning u it .. it only takes a few minutes to do it wen all stuff is in place

ps i have a copy & i live in CLEETHORPES
 

Kryton

<font color="PINK">I LOVE PINK</font>
VIP Member
Joined
Jan 31, 2006
Messages
2,919
Likes
170
#11
If above 2.71 and below 3.03, upgrade to 3.03 and then downgrade to 1.50 using an unpatched copy of Grand Theft Auto Liberty City Stories
it's 2.81 to 3.03 as you can downgrade from 2.80 without gta.

Nightcrawler1 said:
my question is wer can i get unpatched copy of Grand Theft Auto Liberty City Stories or can anyone sell me a copy thats on a disk
maybe ebay will have a copy? or like DEE747 said maybe some 1 would loan you a copy and you pay the postage
unless you fancy a holiday in CLEETHORPES LOL.

i havent got a copy of this so im buggered too if i need to downgrade a 2.81
 
Last edited:

edds

VIP Member
VIP Member
Joined
Mar 5, 2005
Messages
1,509
Likes
30
#13
I had to borrow one myself, but luckily I have two m8s who have the unpatched version. Just had a look on the 'bay and there's loads. Borrow one off a m8, rent one from a video store or take the plunge on the 'bay.
 

DoomedEarl

VIP Member
VIP Member
Joined
Oct 4, 2005
Messages
1,863
Likes
28
#16
My local blockbuster has a copy, as does my local asda believe it or not. I'd try a shop somewhere, familarise yourself with what you are looking for and get it!

In fact my local blockbuster has a unpatched copy for rental which would be even cheaper. Thats what I did when I did mine first of all, then I found out that my nephew had a copy so I got it of him. I'm in Bournemouth area btw.

Good luck
 

fisal

Inactive User
Joined
Feb 24, 2007
Messages
776
Likes
2
#17
mate DONT USE THE OTHER DOWNGRADERS, ONLY USE THE 3.03 DOWNGRADER

he said he had 'psp ic1003' which obvioulsy means he has a ta-082 motherboard,

if he runs any of the other downgraders he will have a brick, use the 3.03 downgrader

nice1
 

Kryton

<font color="PINK">I LOVE PINK</font>
VIP Member
Joined
Jan 31, 2006
Messages
2,919
Likes
170
#18
mate DONT USE THE OTHER DOWNGRADERS, ONLY USE THE 3.03 DOWNGRADER

he said he had 'psp ic1003' which obvioulsy means he has a ta-082 motherboard,

if he runs any of the other downgraders he will have a brick, use the 3.03 downgrader

nice1
he can only use the 3.03 downgrader as he has 2.81 firmware.

also i knew he had a ta-082 board but didnt know what firmware he had at the beginning of the thread. you can downgrade a TA-082 from 2.71 and 2.80 so it's wise to ask first, if he was lucky enough to have 2.80 or under then he wouldn't of needed the gta:lcs game making life much more simpler ;)