Problem with slow browser pages

swanny10

Inactive User
Joined
Jun 16, 2005
Messages
0
Reaction score
1
Hi all hope someone could shed some light on this.

When i am using the internet very often my page just seems to freeze and takes ages to load the page. this is happening with firefox version 3 bets 5, internet explorer 7 and also tried using opera. It doesn't appear to be my internet connection as i am on virgin 20 Mb and when downloading files on newsgroups i get the full speed all the time but when i am browsing the net it just seems to run really slow sometimes. I can visit the same pages and sometimes they will open almost instantly and other times the same pages even this site can take around 30 second or more to open. I have used Advanced windows care which was recommended on another thread on here and that found a few trojans and things and some registry errors which were all fixed and i had hoped that would sort it but still the same problems. Its really doing my head in now has anyone any ideas please.

edit- sorry i probably should have mentioned i am using vista ultimate.

thanks

swanny
 

zhinkler

Inactive User
Joined
Mar 20, 2005
Messages
233
Reaction score
3
could be your browser settings such as phishing filter.
 

little_pob

VIP Member
VIP Member
Joined
Dec 10, 2004
Messages
8,769
Reaction score
2,476
Location
mmm....padded walls....so soft...
If you found a 'few trojans' I'd get an AV on there and do a full scan after booting into safe mode - AVG and Avast do free versions. Also might be worth doing a scan for adware using ad-aware and/or spybot s&d.
 

swanny10

Inactive User
Joined
Jun 16, 2005
Messages
0
Reaction score
1
I already have avg installed and running. i have had that since i first installed this drive and loaded vista onto it.
 
TEST
Top