Phpmyadmin Help!!!!!

Core2Duo

Inactive User
Joined
Mar 4, 2005
Messages
132
Likes
0
#1
Hey

i host a couple of websites but they want to be able to manage there own Mysql Databases but when i take unlimited Acess away it dont make any difference ..

so could i have Some help thxs
 

monkeyspunks

Inactive User
Joined
Apr 9, 1999
Messages
3,054
Likes
0
#2
Hey there amd,

im not understanding fully what your trying to do, or how far you have got with it

Im guessing your giving them there own database and logins, but they can still see each others acconts when they log in, is this right/ the problem your having?
 

Mick

Administrator
Staff member
Administrator
Premium Member
Joined
Jan 19, 1999
Messages
31,855
Likes
826
#3
what control panel are you offering your users ?

you need to set the user permission to there own database and disallow them any other databases, (no permission).

if you are using cpanel it will do this for you (you set it up however), webmin (free cp) will also do this but using webmin is advanced to say the least!

Regards
Mickie D
 

Core2Duo

Inactive User
Joined
Mar 4, 2005
Messages
132
Likes
0
#4
@monkeyspunks yeah that is the correct question i am asking

@ Mickie D i am not using CPanel i am just using Normal PHPmyadmin Login for mysql but i have tried removing the permissions but then i get [email protected] denied

and cant seem to do it .

the server is a 233mhz System wiv 256mb ram

running Apache 2 and mysql n php
 

Mick

Administrator
Staff member
Administrator
Premium Member
Joined
Jan 19, 1999
Messages
31,855
Likes
826
#5
maybe localhost is not the corect database address

if its local try 127.0.0.1 or your fully qualified domain name ?

can you log into your system via ssh or telnet or somehting ?

if you can try typing

mysql -u usernamehere -p passwordhere

to see if you get the no permission on this level of access ?

if phpmyadmin is working flawlessly until you try and do these changes i would check your password is correct (in the config file) check you are using the correct system infomation (localhost) and check that your username johnxp has the priveledges to change these settings you are trying to change.... most linux setups ROOT has the main privledges or you might of created a new user called mysql when creating the whole setup ?


im not sure but i would check that johnxp has the rights to change the system (database) you should be able to grant him full rights with phpmyadmin anyhow depending on the user that is controlling mysql lmao sounds confusing right ;)
 

Mick

Administrator
Staff member
Administrator
Premium Member
Joined
Jan 19, 1999
Messages
31,855
Likes
826
#7
if its wondow server you might need to check the file permissions

and to be honest im not great with windows (as a server), i have it all running on my local machine (windows xp) for backups but never used for a production server ?, so i cant really help soz m8y,

Regards
Mickie D
 

monkeyspunks

Inactive User
Joined
Apr 9, 1999
Messages
3,054
Likes
0
#8
right, think i know what u need

change the line in configinc.php

$cfg['Servers'][$i]['auth_type'] = 'config'; // Authentication method (config, http or cookie based)?

to

$cfg['Servers'][$i]['auth_type'] = 'http'; // Authentication method (config, http or cookie based)?


Then go to the privlages

click on a user,

deselect all his permissions

then just under that box where it says

"Database-specific privileges"
select the table they should have acess to and click go then set the permissions for that table.

I think thats it then

let me know

tar
monks
 
TEST
Top