OpenATV 6.3 dm800sev2 sim2 image daily build

gjstroom

VIP Member
VIP Member
Joined
Dec 20, 2015
Messages
122
Usb works, no problem. Please don't post in multiple threads.
 

axlrose

New Member
Joined
Oct 1, 2011
Messages
6
tested on dm800 se v1 sry but this image have problem to format usb mount no working
 
Last edited:

gjstroom

VIP Member
VIP Member
Joined
Dec 20, 2015
Messages
122
I can't help if your only message is, it doesn't work.
Please clarify your steps. What kind of usb device are you using ?
My box has both a 500G hdd and 2G usb disk and they work fine.
/dev/sda1 on /media/hdd type ext4 (rw,relatime,barrier=1,data=ordered)
/dev/sdb1 on /media/usb type ext4 (rw,relatime,barrier=1,data=ordered)
Initialisation of a storage device takes some time.
I did not test the initialization menu's, because my disks are already in an working format.
If you are using devices which are in fat or xfat format it can cause problems, i would go for a ext4 formated disk.
Try to completely erase the usb first to get rid of already existing partition tables.

Also storage devices are the first to fail when you powersupply is bad (blown capacitors).
 
Last edited:

gjstroom

VIP Member
VIP Member
Joined
Dec 20, 2015
Messages
122
It appears the mkfs version used, uses an option which is not supported by the mount command, so we need to create a filesystem which doesn't use the metadata_csum feature !

I made a little how to initialize disks using the command line (telnet/ssh)

First we stop enimga2 and make sure which device you want to initialize (I removed the irrelevant lines):

Code:
You don't have permission to view the code content. Log in or register now.
In my case it's a 8GB usb flash disk and the device is sdc which now has an FAT32 partition
As a result I use /dev/sdc in all commands down below, please change it to your device.

Make sure the partition isn't in use
Code:
You don't have permission to view the code content. Log in or register now.
I want to get rid of the existing partitions, ALL DATA WILL BE LOST !
Code:
You don't have permission to view the code content. Log in or register now.
Check again the current layout, you notice the partion(s) are gone.
Code:
You don't have permission to view the code content. Log in or register now.
Write new partition to the disk
Code:
You don't have permission to view the code content. Log in or register now.
Make new EXT4 filesystem on the disk
Code:
You don't have permission to view the code content. Log in or register now.
Reboot the box
 
Last edited:

axlrose

New Member
Joined
Oct 1, 2011
Messages
6
i am using san disk cruzer 2gb open atv 6.2, 6.1 verzion, is ok mount no problemes but this 6.3 no mount usb go to 99% and stop give me this mesage :
initializing storage device ...
Error: Timeout elapsed, sorry


i no have problem with capacitors open atv 6.2 works well usb
 

gjstroom

VIP Member
VIP Member
Joined
Dec 20, 2015
Messages
122
I submitted a change to OpenATV, I think it will be solved in a few days.
If you can't wait, you can upload the fixed file to your box.
Enter the following commands on your telnet/ssh console:
Code:
You don't have permission to view the code content. Log in or register now.
unzip Harddisk.zip
now upload the new Harddisk.py using ftp or scp to /usr/lib/enigma2/python/Components/
Code:
You don't have permission to view the code content. Log in or register now.
 

Attachments

TEST
Top