• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Lcd-epg

Joined
Mar 12, 2006
Messages
0
Likes
0
#1
Any chance of a tut for getting LCD-EPG to work on these images, I've tried it but I'm really struggling :(. Thanks
 

gav12345

VIP Member
VIP Member
Joined
Mar 11, 2005
Messages
5,308
Likes
41
#2
Any chance of a tut for getting LCD-EPG to work on these images, I've tried it but I'm really struggling :(. Thanks
hi m8

what can i say i would really love to help here but i do not use this feature but i will have a look for you though

please state where you are and what files you got and what you are stuck on

i will do some research and make it a challenge for me to try and get a guide done for you but it will need to be with your help too m8

as i said i dont use that feature personnally but i would play for you



cheers
 
Joined
Mar 12, 2006
Messages
0
Likes
0
#3
Well, i used a mixture of the files straight from the keywelt board and the english translated ones from njl:world 3, problem is it comes up "No EPG Info", haven't tried anything like that before so abit stumped
 

gav12345

VIP Member
VIP Member
Joined
Mar 11, 2005
Messages
5,308
Likes
41
#4
ok sorry as you know im new to this i thought maybe someone else would of seen this before me so if someone that knows what they are doing please but in as i am a newby to this as well


ok the lcdmenu.conf is the file that you need in the var/tuxbox/config folder of the dbox

then in the lcd menu there should be a way of configuring this file to enable the epg on the lcd

hope im right just looking at some of the files now



cheers
 

gav12345

VIP Member
VIP Member
Joined
Mar 11, 2005
Messages
5,308
Likes
41
#5
lcd_epg needs to go in var/plugins this needs to be chmod 755

you will need to modify the shellexec.conf so it says something like this



MENU=LCD-EPG
DEPENDOFF=Activate LCD-EPG,/var/plugins/lcd_epg,/tmp/.lcd_epg.on
DEPENDON=Deactivate LCD-EPG,/var/plugins/lcd_epg,/tmp/.lcd_epg.on
MENU=LCD-EPG Setup
SHELLRESON=-&LCD-EPG - View 1,CONFIG=`cat /var/tuxbox/config/lcd_epg.conf`; echo "$CONFIG" | sed -e 's/^LCD_ANSICHT=.*/LCD_ANSICHT=1/' > /var/tuxbox/config/lcd_epg.conf,[ -s /var/tuxbox/config/lcd_epg.conf ] && grep -q '^LCD_ANSICHT=[23]' /var/tuxbox/config/lcd_epg.conf,Please Wait
SHELLRESON=-&LCD-EPG - View 2,CONFIG=`cat /var/tuxbox/config/lcd_epg.conf`; echo "$CONFIG" | sed -e 's/^LCD_ANSICHT=.*/LCD_ANSICHT=2/' > /var/tuxbox/config/lcd_epg.conf,[ -s /var/tuxbox/config/lcd_epg.conf ] && grep -q '^LCD_ANSICHT=[13]' /var/tuxbox/config/lcd_epg.conf,Please Wait
SHELLRESON=-&LCD-EPG - View 3,CONFIG=`cat /var/tuxbox/config/lcd_epg.conf`; echo "$CONFIG" | sed -e 's/^LCD_ANSICHT=.*/LCD_ANSICHT=3/' > /var/tuxbox/config/lcd_epg.conf,[ -s /var/tuxbox/config/lcd_epg.conf ] && grep -q '^LCD_ANSICHT=[12]' /var/tuxbox/config/lcd_epg.conf,Please Wait
DEPENDON=*-&Reload LCD-EPG Config,touch /tmp/.lcd_epg.reload; sleep 6,/tmp/.lcd_epg.on,Please Wait
DEPENDON=&LCD-EPG AutoStart~T~T~TOn,rm /var/etc/.lcd_epg_auto,/var/etc/.lcd_epg_auto,Please Wait
DEPENDOFF=&LCD-EPG AutoStart~T~T~TOff,touch /var/etc/.lcd_epg_auto,/var/etc/.lcd_epg_auto,Please Wait
COMMENT=*
COMMENT=For the the LCD-EPG AutoStart
COMMENT=you need to restart neutrino!
ENDMENU
ENDMENU



with thanks to the commando team for this
 
Last edited:
Joined
Mar 12, 2006
Messages
0
Likes
0
#6
Still get the same error, can't see what to edit to get the EPG to show :(
Thanks for all your help so far yido, appreciated
 

nj2006

Inactive User
Joined
Feb 13, 2006
Messages
683
Likes
7
#7
hold on m8 give us a minute to read the thread and get the files together and i will do a tut for you . this one is easy to install when you know how .
 
Joined
Oct 3, 2005
Messages
736
Likes
13
#8
have u had a look at the commando 7.5 image it has all the lcd stuff in there, probably easy to copy, I can get you the root if you want
 

nj2006

Inactive User
Joined
Feb 13, 2006
Messages
683
Likes
7
#10
are you editing a jffs2 image or a squash one ?

do you have the box connected to internet ?
 

nj2006

Inactive User
Joined
Feb 13, 2006
Messages
683
Likes
7
#12
sounds like you need busyboxse
and some extra symlinks m8

put these 2 files into the temp

telnet into the box

type this in

Code:
chmod 755 /tmp/installbbse 
/tmp/installbbse

this will install whats needed to get it to run .
 
Last edited:

nj2006

Inactive User
Joined
Feb 13, 2006
Messages
683
Likes
7
#14
Install lcd epg.

unpack lcd epg folder
keeping the file structure upload to the dbox .

getrc /var/bin/ 755
lcd_epg.sh /var/plugins/ 755
lcd_epg.conf /var/tuxbox/config/ 644


Optnal on / off on plugin menu
***********************************
lcd_epg.so /var/tuxbox/plugins/ 755
lcd_epg.cfg /var/tuxbox/plugins/ 644
lcd_epg /var/tuxbox/plugins/ 755
*************************************

recording.start /var/tuxbox/config/ 755
recording.end /var/tuxbox/config/ 755
recording.timer /var/tuxbox/config/ 755
pictureviewer.start /var/tuxbox/config/ 755
pictureviewer.end /var/tuxbox/config/ 755

insert this in start neutrino to get it to auto run

Code:
look for this

/bin/neutrino -u -f

then put this after

if [ -e /var/etc/.lcd_epg_auto ] ; then
    sleep 30 && /var/plugins/lcd_epg.sh &
fi

/bin/neutrino -u -f

if pidof lcd_epg.sh > /dev/null; then
    /var/plugins/lcd_epg.sh
    sleep 3
    wget -q -Y off -O - 'http://localhost/control/lcd?lock=1&clear=1&update=1&png=/share/tuxbox/lcdd/icons/power.png'
fi


then use the stuff in the post up from this .
 
Last edited:
Joined
Mar 12, 2006
Messages
0
Likes
0
#15
Can you give me some help on the start_neutrino side, cant see /bin/neutrino -u -f to insert it all, ive attached the file
 
Joined
Mar 12, 2006
Messages
0
Likes
0
#17
Having absolultly no luck with it at all, can you have a look and see what im doing wrong?
#!/bin/sh

# $Id: start_neutrino,v 1.30 2006/07/23 12:21:37 barf Exp $

date -s 010101001970
sectionsd
timerd
/var/bin/mmops startdefaultemu noGUI
zapit
controld
nhttpd
until neutrino -f -u ; do
echo "Neutrino exited with nonzero exit status, restarting..."
pidof sectionsd >/dev/null || sectionsd
pidof timerd >/dev/null || timerd
pidof camd2 >/dev/null || camd2
pidof zapit >/dev/null || zapit
pidof controld >/dev/null || controld
pidof nhttpd >/dev/null || nhttpd
done

[ -e /tmp/tuxmaild.pid ] && kill $( cat /tmp/tuxmaild.pid )
[ -e /tmp/tuxcald.pid ] && kill $( cat /tmp/tuxcald.pid )
[ -e /var/run/automount.pid ] && kill -TERM $( cat /var/run/automount.pid )
pzapit -kill

i=9
while expr $i != 0 > /dev/null
do
if pidof controld > /dev/null; then echo "Waiting for controld (max. $i seconds)"
elif pidof timerd > /dev/null; then echo "Waiting for timerd (max. $i seconds)"
elif pidof zapit > /dev/null; then echo "Waiting for zapit (max. $i seconds)"
elif pidof tuxmaild > /dev/null; then echo "Waiting for tuxmaild (max. $i seconds)"
elif pidof tuxcald > /dev/null; then echo "Waiting for tuxcald (max. $i seconds)"
else break;
fi
i=`expr $i - 1`
sleep 1
done

if [ -e /var/etc/.lcd_epg_auto ] ; then
sleep 30 && /var/plugins/lcd_epg.sh &
fi

/bin/neutrino -u -f

if pidof lcd_epg.sh > /dev/null; then
/var/plugins/lcd_epg.sh
sleep 3
wget -q -Y off -O - 'http://localhost/control/lcd?lock=1&clear=1&update=1&png=/share/tuxbox/lcdd/icons/power.png'
fi

if [ -e /tmp/.nohalt ] ; then
killall -q sectionsd
killall -q timerd
killall -q camd2
killall -q zapit
killall -q controld
killall -q nhttpd
saa --fbas
switch -fnc 0 -fblk 0
echo "Neutrino and its daemons terminated (hopefully)"
exit
fi

if [ -e /tmp/.reboot ] ; then
reboot
else
halt
fi
 

nj2006

Inactive User
Joined
Feb 13, 2006
Messages
683
Likes
7
#18
it should be this sorry


Code:
/bin/neutrino -u -f

if [ -e /var/etc/.lcd_epg_auto ] ; then
    sleep 30 && /var/plugins/lcd_epg.sh &
fi

/bin/neutrino -u -f

if pidof lcd_epg.sh > /dev/null; then
    /var/plugins/lcd_epg.sh
    sleep 3
    wget -q -Y off -O - 'http://localhost/control/lcd?lock=1&clear=1&update=1&png=/share/tuxbox/lcdd/icons/power.png'
fi
you will need to turn the auto start on in shelexec menu .

or telnet into the box and
Code:
touch /var/etc/.lcd_epg_auto
 
Joined
Mar 12, 2006
Messages
0
Likes
0
#19
Still nothing, getting a wierd bug now aswell when i press restart or shutdown neutrino restarts without channel lists etc, takes a good 3 restarts to get it to eventually restart
 

nj2006

Inactive User
Joined
Feb 13, 2006
Messages
683
Likes
7
#20
try this code m8 .
it works on my v4 image i changed it to your emu selection .

Code:
#!/bin/sh

# $Id: start_neutrino,v 1.30 22/03/07 Njlworldv4 $

date -s 010101001970
sectionsd
timerd
/var/bin/mmops startdefaultemu noGUI
camd2
zapit
controld
nhttpd

if [ -e /var/etc/.lcd_epg_auto ] ; then
    sleep 30 && /var/plugins/lcd_epg.sh &
fi

/bin/neutrino -u -f

if pidof lcd_epg.sh > /dev/null; then
    /var/plugins/lcd_epg.sh
    sleep 3
    wget -q -Y off -O - 'http://localhost/control/lcd?lock=1&clear=1&update=1&png=/share/tuxbox/lcdd/icons/power.png'
fi
[ -e /tmp/tuxmaild.pid ] && kill $( cat /tmp/tuxmaild.pid )
[ -e /tmp/tuxcald.pid ] && kill $( cat /tmp/tuxcald.pid )
[ -e /var/run/automount.pid ] && kill -TERM $( cat /var/run/automount.pid )
pzapit -kill

i=9
while expr $i != 0 > /dev/null
do
if pidof controld > /dev/null; then echo "Waiting for controld (max. $i seconds)"
elif pidof timerd > /dev/null; then echo "Waiting for timerd (max. $i seconds)"
elif pidof zapit > /dev/null; then echo "Waiting for zapit (max. $i seconds)"
elif pidof tuxmaild > /dev/null; then echo "Waiting for tuxmaild (max. $i seconds)"
elif pidof tuxcald > /dev/null; then echo "Waiting for tuxcald (max. $i seconds)"
else break;
fi
i=`expr $i - 1`
sleep 1
done


if [ -e /tmp/.nohalt ] ; then
    killall -q sectionsd
    killall -q timerd
    killall -q camd2
    killall -q zapit
    killall -q controld
    killall -q nhttpd
    saa --fbas
    switch -fnc 0 -fblk 0
    echo "Neutrino and its daemons terminated (hopefully)"
    exit
fi

if [ -e /tmp/.reboot ] ; then
    reboot
else
    halt
fi