Is 3.03oe safe?

MC_1

Inactive User
Joined
Jun 15, 2005
Messages
70
Reaction score
0
After I had plucked up the courage to downgrade my psp to a 1.5, I found it very simple to install devhooks 1.5 to 2.70 (or something similar?). It just involved connecting my psp to the computer and transfering a few files - automatically. I was so relieved that I didnt brick my psp!

Can anyone tell me if the 3.03oe is this easy to install and is it the best one I should upgrade to? Also, is it safe as using the devhook one I used to use because I definately dont want a brick!
When it comes to upgrading, I become nervous and prefer to ask you guys for the advice first.
 

biffo1

Moderator
Staff member
Moderator
Joined
Dec 5, 2006
Messages
9,096
Reaction score
2,127
Location
Manchester
yep can confirm 3.10a works a treat no way im going back to 1.50 , it can only get better
 

allcards

Inactive User
Joined
Jan 18, 2006
Messages
32
Reaction score
0
Ya its safe,

but make sure you reset the psp to 1.5 before installing

regards
 

Bally12345

VIP Member
VIP Member
Joined
Dec 27, 2005
Messages
8,527
Reaction score
721
Agree with above comments... Had no problems with it at all and was very quick and easy to install :)
 

MC_1

Inactive User
Joined
Jun 15, 2005
Messages
70
Reaction score
0
Thanks Guys, Im definiately going to upgrade now. Hope it works well
 

illumin

Inactive User
Joined
Feb 6, 2007
Messages
30
Reaction score
0
Does the ps1 emulator work ok in this release as ive had probs before and had to downgrade?
 
TEST
Top