How to get OSCAM working on DM600 with PLI Jade 3 - Enigma 1

The Dentist

VIP Member
VIP Member
Joined
Apr 2, 2006
Messages
8,321
Reaction score
1,023
Location
London
ok cool cheers guys. gonna try restarting both and starting one after another....when i work out how lol

EDIT: im using telnet

just done killal cccam and killall oscam

when restarting oscam, i noticed it threw up a warning. something so silly. it goes password in account not recognised.

realised the field password = 5ky should be pwd = 5ky!!

really hope that was the issue lol

how long does it take to start up oscam?? its still flashing away

EDIT 2: in telnet, cccam starts up straight away but oscam just goes along flashing cursor but nothing happens :(
 
Last edited:

Abu Baniaz

VIP Member
VIP Member
Joined
Mar 30, 2008
Messages
6,262
Reaction score
2,439
Location
East London
Easiest way for now is to telnet, amend names or file paths when you restart. Oscam has options in web interface. You should also be able to do so in the softcam sections.

killall CCcam
killall Oscam

/var/bin/Oscam
/var/bin/CCcam
 

wiz569

VIP Member
VIP Member
Joined
Feb 25, 2007
Messages
11,974
Reaction score
6,174
Location
Ireland
ok cool cheers guys. gonna try restarting both and starting one after another....when i work out how lol

EDIT: im using telnet

just done killal cccam and killall oscam

when restarting oscam, i noticed it threw up a warning. something so silly. it goes password in account not recognised.

realised the field password = 5ky should be pwd = 5ky!!

really hope that was the issue lol

how long does it take to start up oscam?? its still flashing away

EDIT 2: in telnet, cccam starts up straight away but oscam just goes along flashing cursor but nothing happens :(
oscam should start up almost immediately m8,and there will be loads of writing scrolling up the screen
 

wiz569

VIP Member
VIP Member
Joined
Feb 25, 2007
Messages
11,974
Reaction score
6,174
Location
Ireland
If the above is not happening when you start oscam, then regardless of what CCcam does afterward, its not going to work,

oscam should first of all look for its cfgs,and throw up errors if it doesnt find them,
if its not even doing that then that version of oscam is not for you m8
 

The Dentist

VIP Member
VIP Member
Joined
Apr 2, 2006
Messages
8,321
Reaction score
1,023
Location
London
Hello! Im back lol.

I got just oscam on there now. got rid off cccam.

Want to start with local channels first. On the local box, ie, on the box itself, it is clearing everything apart from sports and movies which is quite confusing. The discovery channels are paid channels so how comes they are clearing and not the others? Is there any place where you can pick and choose?
 

wiz569

VIP Member
VIP Member
Joined
Feb 25, 2007
Messages
11,974
Reaction score
6,174
Location
Ireland
You need to enter your boxkey in oscam.conf,
Its needed it some versions of oscam,so it might be the case in yours :)
 

The Dentist

VIP Member
VIP Member
Joined
Apr 2, 2006
Messages
8,321
Reaction score
1,023
Location
London
where does it go in there mate?
i thought it goes in there?
I got it under boxid in oscam.server
 

wiz569

VIP Member
VIP Member
Joined
Feb 25, 2007
Messages
11,974
Reaction score
6,174
Location
Ireland
Post your configs m8 and we can check them out
 

The Dentist

VIP Member
VIP Member
Joined
Apr 2, 2006
Messages
8,321
Reaction score
1,023
Location
London
cccam.cfg
N: 127.0.0.1 10000 espn 5ky 01 02 03 04 05 06 07 08 09 10 11 12 13 14 256
oscam.conf
[global]
clientmaxidle = 300
maxlogsize = 10000
nice = -1
WaitForCards = 1
preferlocalcards = 1
saveinithistory = 1
serverip= 192.168.0.103
failbancount = 5
failbantime = 7200


# logging


logfile = /var/log/oscam.log
usrfile = /var/log/oscamuser.log
cwlogdir = /opt/oscam/cw


# monitor


[monitor]
port = 988
nocrypt = 127.0.0.1,192.168.x.x
aulow = 120
monlevel = 1


# web interface


[webif]
httpport = 16002
httpuser = myuser
httppwd = mypswrd
httprefresh = 5
httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255


protocols


[cccam]
port = 12001
reshare = 1
ignorereshare = 0
forward_origin_card = 0
version = 2.3.0
updateinterval = 240
minimizecards = 0
keepconnected = 1
stealth = 1
reshare_mode = 1


[newcamd]
key = 0102030405060708091011121314
port = [email protected]:000000
allowed = 127.0.0.1,192.168.0.0-192.168.255.255
keepalive = 1
debug = 255


[dvbapi]
enabled = 1
au = 1
boxtype = dreambox
user = myname
request_mode = 0
oscam.server
[reader]
label = uk
enable = 1
protocol = internal
device = /dev/sci0
detect = cd
mhz = 500
cardmhz = 357
caid = 0963
boxid = 11 11 11 11 << oviously this is my own one
ident = 0963:000000
group = 1
cacheex = 1
emmcache = 1,3,2
ecmcache = 1
dropbadcws = 1
blockemm-g = 1
blockemm-unknown = 1
blockemm-u = 0
blockemm-s = 0
lb_weight = 101
ecmwhitelist = [email protected]000:3E,42,44,45,47,4E,53,54,61,62,68,69,6A,6B,6D,6F, 71,72,73,77,78,79,7A,7C,7D,7E,80,8B
oscam.user
[account]
user = espn
pwd = 5ky
description = newcamd
disabled = 0
uniq = 1
group = 1
au = internal
caid = 0963:000000
 
Last edited by a moderator:

wiz569

VIP Member
VIP Member
Joined
Feb 25, 2007
Messages
11,974
Reaction score
6,174
Location
Ireland
Hmm ok first you can disable newcamd protocol and either remove or hash out the nline in your cfg,
secondly remove the whitelist as its missing some numbers,

see if that helps before we move on :)
 

The Dentist

VIP Member
VIP Member
Joined
Apr 2, 2006
Messages
8,321
Reaction score
1,023
Location
London
Hmm ok first you can disable newcamd protocol and either remove or hash out the nline in your cfg,
secondly remove the whitelist as its missing some numbers,

see if that helps before we move on :)
ok mate,

hashed out everything in newcamd so it looks like this:

#[newcamd]
#key = 0102030405060708091011121314
#port = [email protected]:000000
#allowed = 127.0.0.1,192.168.0.0-192.168.255.255
#keepalive = 1
#debug = 255

hashed out the n line in cccam.cfg so the cccam file is blank now.
i also hashed out the ecm whitelist bit.

rebooted box....still same.
everything works apart from sports and movies.
funnily enough discovery and sly1 works though.
 

wiz569

VIP Member
VIP Member
Joined
Feb 25, 2007
Messages
11,974
Reaction score
6,174
Location
Ireland
Ok try creating a user account for the dvbapi i.e.

[account]
user = matching username from the dvbapi entry in oscam.conf
group = 1
au = 1

you can disable the other user account
 

The Dentist

VIP Member
VIP Member
Joined
Apr 2, 2006
Messages
8,321
Reaction score
1,023
Location
London
Ok try creating a user account for the dvbapi i.e.

[account]
user = matching username from the dvbapi entry in oscam.conf
group = 1
au = 1

you can disable the other user account
Ok done that mate...still same thing.. :(
 

wiz569

VIP Member
VIP Member
Joined
Feb 25, 2007
Messages
11,974
Reaction score
6,174
Location
Ireland
Can you access the webif?
Also any edits you make,be sure to do them with a unix editor
 

The Dentist

VIP Member
VIP Member
Joined
Apr 2, 2006
Messages
8,321
Reaction score
1,023
Location
London
nah entitlements are fine mate. was working this morning with cccam lol. i have unistalled cccam from the box altogether.
yep i can access webif and have done with unix editor. made sure that the files are in unix format.
 

wiz569

VIP Member
VIP Member
Joined
Feb 25, 2007
Messages
11,974
Reaction score
6,174
Location
Ireland
nah entitlements are fine mate. was working this morning with cccam lol. i have unistalled cccam from the box altogether.
yep i can access webif and have done with unix editor. made sure that the files are in unix format.
Ok so what is the log saying when you try watch sport or movies?
 

The Dentist

VIP Member
VIP Member
Joined
Apr 2, 2006
Messages
8,321
Reaction score
1,023
Location
London
in the webinf, in the status page at the bottom, im getting a lot of channel not subscribed coming up.

r [videoguard2-reader] classD3 ins54: status 90 00 = ok but cw=00 -> channel not subscribed
 

The Dentist

VIP Member
VIP Member
Joined
Apr 2, 2006
Messages
8,321
Reaction score
1,023
Location
London
its not every user tho. see a portion here:

2012/11/17 18:21:47 10279388 c user1(0963&000000/0000/C5D0/62:8EA5): found (79 ms) by ***uk
2012/11/17 18:21:47 102A0078 c user1(0963&000000/0000/1796/62:EC51): found (78 ms) by ***uk
2012/11/17 18:21:48 102A1970 c user2(0963&000000/0000/1BBD/62:5A18): found (78 ms) by ***uk
2012/11/17 18:21:48 1024EA40 r [videoguard2-reader] classD3 ins54: status 90 00 = ok but cw=00 -> channel not subscribed
2012/11/17 18:21:48 1027F6E8 c user1(0963&000000/0000/C51C/3E:B567): not found (45 ms) by ***uk
 
Last edited by a moderator:
TEST
Top