FTP problem, can connect fine but.......


Inactive User
Aug 19, 2005
Reaction score
Never had a problem ftping into my box before but ive just tried to load a new img via ftp and it got so far and then failed the transfer,
i tried to del the partial img but no luck it just says
Delete operation failed

tried to del some of the games that ive got on the box and the same thing
Delete operation failed

i can look through all the dirs on my box fine and i can transfer from the box to the pc, just cant del anything on the box or transfer to it...

Any ideas ?
Maybe reboot the box and try again. Make sure you're logged in as root. If you're really stuck, you could flash the box with IFA.
rebooted the box about 4 times now, not changed any log in details from when its been working for months.
just checked the login details and its all correct
its not the ftp program, all other connections are fine, been using flash for years so i know its not that
Could just be a duff image - or maybe your box is a 16MB one and alot of memory has been taken up; in that case you wont be able to use FTP to flash the image.
i found when i got my box my box ip address was it said it was in the instructions plus i checked it and it was then i flashed an image onto it and then ithought right ill sort out the bouquet file into a local order by loading one on through ftp using flash fxp but i couldnt connect so i thought il lcheck the ip on the box and it had changed so give it a try because it depends what the ip address is set to on the image.

for reference though the ip address i use on the card in my pc is i did use but i was getting nowhere with that.
"Never had a problem ftping into my box before "

the image is fine, been on the box for ages and never had a prob ftping before with it.

the ip is exactly the same as i set it to, i couldnt connect if it was different!

Id try ifa but that wouldnt change anything realy,
it still wouldnt explain why i cant del anything off the box or ftp any files over to it without getting
'operation failed'

tried it from another pc and same problem... very odd!
OK basically you are getting the 'operation failed' message because the image has locked itself. This sometimes happens when you put too much data into the image (remember the flash chips only hold 8MB and if you go over this then the FTP will fail and all future FTP operations will refuse to function). There are also other reasons why this would happen.

It shouldnt however affect the /TMP folder... the only reason why it would 'fail' an operation in the tmp folder is if the dbox had ran out of memory (which is a common problem on 16mb boxes), in that case you have no option but to use IFA to flash.

Liam :)
cool, thanks for the info, ill flash it with ifa and the img thats on it now and see if i can then ftp back in
thanks for the info liam, just used ifa,
took ages as couldnt be bothered to hook up the null cable,

all fine now :)