Dbox II Problems

Dancer73

New Member +
Joined
Mar 13, 2005
Messages
86
Likes
0
#1
Hi all

Have had my dbox II running for a few weeks now. Today i switched on and although the lcd screen does the usual loading neutrino etc ,no start image appears and no picture just a blank screen.It seems to be running ok i can see the channels,dbox menu etc on the lcd screen but not the telly.Any ideas?
 

Fergalsworld

VIP Member
VIP Member
Joined
May 5, 2005
Messages
4,391
Likes
72
#2
The cable feed has'nt popped out has it
If its a sporster image
press blue
press blue and wait
press green and wait then
press red and wait this will restart evocamd
but rebooting does this aswell,
worth a shot if it dont work
get back blank screen and
press red then blue and post you ber snr and sig levels if they will appear on the screen.
You could always flash another image on
Hope this helps.
 

Dancer73

New Member +
Joined
Mar 13, 2005
Messages
86
Likes
0
#3
Cheers But no joy.I'm using gav's image from last month(windows xp image).Stream information was blank.I thought about flashing a new image but i've been using flash fxp to do it manually and it's a lot easier if u can see the dbox menu on the telly.Couldn't get ifa or dbox command to work for me.
 

Dancer73

New Member +
Joined
Mar 13, 2005
Messages
86
Likes
0
#4
Tried reflashing my old image on to the dbox but still the same.I notice that the time on the lcd starts from 01:00 and the programme status bar on the lcd has a line diagonally across instead of showing the time/length of it
 

Dancer73

New Member +
Joined
Mar 13, 2005
Messages
86
Likes
0
#7
Yeah i tried different scart and tell,the signal's fine as i tried a mates dbox which worked ok.It did the same the other day but it eventually started proper.The only thing i can think is the scart connection to the board inside...This is doin my head in!!!
 

Dancer73

New Member +
Joined
Mar 13, 2005
Messages
86
Likes
0
#8
How do i check the log using a null modem? I manually ftp the image using flash fxp as i can't get ifa to work cheers
 

Dancer73

New Member +
Joined
Mar 13, 2005
Messages
86
Likes
0
#9
hi all

Managed to get a null modem cable here is the bootlog any help is appreciated thanks debug: Got Block #0040

will verify ELF image, start= 0x800000, size= 152952
verify sig: 263
Branching to 0x40000


U-Boot 1.1.2 (TuxBox) (May 23 2004 - 21:44:01)

CPU: PPC823ZTnnB2 at 66 MHz: 2 kB I-Cache 1 kB D-Cache
Board: DBOX2, Sagem, BMon V1.3
Watchdog enabled
I2C: ready
DRAM: 32 MB
FLASH: 8 MB
Scanning JFFS2 FS: ........ done.
FB: ready
LCD: ready
In: serial
Out: serial
Err: serial
Net: SCC ETHERNET

Options:
1: Console on null
2: Console on ttyS0
3: Console on framebuffer
Select option (1-3), other keys to stop autoboot: 0
...............................................................
Un-Protected 63 sectors
### FS (jffs2) loading 'vmlinuz' to 0x100000
### FS load complete: 631075 bytes loaded to 0x100000
## Booting image at 00100000 ...
Image Name: dbox2
Image Type: PowerPC Linux Kernel Image (gzip compressed)
Data Size: 631011 Bytes = 616.2 kB
Load Address: 00000000
Entry Point: 00000000
Verifying Checksum ... OK
Uncompressing Kernel Image ... OK
Linux version 2.4.31-dbox2 ([email protected]) (gcc version 3.3.5) #25 Sa Jul
30 18:26:20 CEST 2005
On node 0 totalpages: 8192
zone(0): 8192 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Kernel command line: root=/dev/mtdblock2 rw console=ttyS0
Decrementer Frequency = 247500000/60
m8xx_wdt: active wdt found (SWTC: 0xFFFF, SWP: 0x1)
m8xx_wdt: keep-alive trigger installed (PITC: 0x2580)
Console: colour dummy device 80x25
Calibrating delay loop... 65.74 BogoMIPS
Memory: 30864k available (1076k kernel code, 368k data, 60k init, 0k highmem)
Dentry cache hash table entries: 4096 (order: 3, 32768 bytes)
Inode cache hash table entries: 2048 (order: 2, 16384 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 1024 (order: 0, 4096 bytes)
Page-cache hash table entries: 8192 (order: 3, 32768 bytes)
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
devfs: v1.12c (20020818) Richard Gooch ([email protected])
devfs: boot_options: 0x1
JFFS2 version 2.2. (NAND) (C) 2001-2003 Red Hat, Inc.
i2c-core.o: i2c core module version 2.6.1 (20010830)
i2c-dev.o: i2c /dev entries driver module version 2.6.1 (20010830)
CPM UART driver version 0.04
ttyS0 at 0x0280 is on SMC1 using BRGttyS1 at 0x0380 is on SMC2 using BRG2
pty: 256 Unix98 ptys configured
eth0: CPM ENET Version 0.2.dbox2 on SCC2, 00:50:9c:3e:0f:fa
D-Box 2 flash driver (size->0x800000 mem->0x10000000)
D-Box 2 flash memory: Found 1 x16 devices at 0x0 in 16-bit bank
Intel/Sharp Extended Query Table at 0x0031
Using buffer write method
cfi_cmdset_0001: Erase suspend on write enabled
Creating 5 MTD partitions on "D-Box 2 flash memory":
0x00000000-0x00020000 : "BR bootloader"
0x00020000-0x00040000 : "FLFS (U-Boot)"
0x00040000-0x00800000 : "root (JFFS2)"
0x00020000-0x00800000 : "Flash without bootloader"
0x00000000-0x00800000 : "Complete Flash"
Linux video capture interface: v1.00
mice: PS/2 mouse device common for all mice
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 2048 bind 4096)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
cramfs: wrong magic
VFS: Mounted root (jffs2 filesystem).
Mounted devfs on /dev
Freeing unused kernel memory: 60k init
Starting pid 11, console /dev/console: '/etc/init.d/rcS'ti-call b
Using /lib/modules/2.4.31-dbox2/misc/event.o
event: $Id: event.c,v 1.12 2003/09/30 05:45:38 obi Exp $
Using /lib/modules/2.4.31-dbox2/misc/tuxbox.o
Using /lib/modules/2.4.31-dbox2/misc/dvb-core.o
Using /lib/modules/2.4.31-dbox2/misc/dbox2_i2c.o
[i2c-8xx]: mpc 8xx i2c init
[i2c-8xx]: adapter: 0
Using /lib/modules/2.4.31-dbox2/misc/dbox2_fp.o
Using /lib/modules/2.4.31-dbox2/misc/dbox2_fp_input.o
Using /lib/modules/2.4.31-dbox2/misc/avs.o
Oops: kernel access of bad area, sig: 11
NIP: C009FB20 XER: 00000000 LR: C389B514 SP: C1DC7E30 REGS: c1dc7d80 TRAP: 0300
Not tainted
MSR: 00009032 EE: 1 PR: 0 FP: 0 ME: 1 IR/DR: 11
DAR: 00000024, DSISR: C0000000
TASK = c1dc6000[23] 'insmod' Last syscall: 128
last math 00000000 last altivec 00000000
GPR00: C389B514 C1DC7E30 C1DC6000 C389D648 C389D626 00000007 C012A2EC 00000019
GPR08: 00000000 00000004 0000003F C009FB08 24008022 1007218C 00000000 00000000
GPR16: 00000000 00000000 00000000 00000000 00009032 1014BFCC C1D2A000 C1DC7EA0
GPR24: C1F0CCC0 00000003 C389F000 FFFFFFEA C0130000 00000007 00000000 00000000
Call backtrace:
C389C26C C389B514 C389C9D8 C0010694 C000257C 10148DA8 1001CFEC
1001E314 10003DBC 100039F8 0FEEF464 00000000
Segmentation fault
Using /lib/modules/2.4.31-dbox2/misc/saa7126.o
i2c-core.o: driver saa7126 registered.
i2c-core.o: client [saa7126] registered to adapter [PowerPC 8xx I2C adapter](pos
. 1).
Detected STB:
Vendor: Sagem
Model: D-BOX2
Using /lib/modules/2.4.31-dbox2/misc/cam.o
$Id: cam.c,v 1.30 2004/01/10 16:36:34 alexw Exp $
i2c-core.o: driver DBox2-CAM registered.
i2c-core.o: client [DBox2-CAM] registered to adapter [PowerPC 8xx I2C adapter](p
os. 2).
Using /lib/modules/2.4.31-dbox2/misc/dvb_i2c_bridge.o
Using /lib/modules/2.4.31-dbox2/misc/avia_napi.o
$Id: avia_napi.c,v 1.18 2003/11/24 09:53:01 obi Exp $
DVB: registering new adapter (C-Cube AViA GTX/eNX with AViA 500/600).
i2c-core.o: driver DVB I2C bridge registered.
i2c-core.o: client [DVB I2C bridge] registered to adapter [PowerPC 8xx I2C adapt
er](pos. 3).
dvb_i2c_bridge: enabled DVB i2c bridge to PowerPC 8xx I2C adapter
Using /lib/modules/2.4.31-dbox2/misc/cam_napi.o
$Id: cam_napi.c,v 1.8 2003/09/30 05:45:34 obi Exp $
Using /lib/modules/2.4.31-dbox2/misc/dbox2_fp_napi.o
Using /lib/modules/2.4.31-dbox2/misc/avia_av_alt.o
route: SIOC[ADD|DEL]RT: Network is unreachable
avia_av: $Id: avia_av_core.c,v 1.89 2004/02/27 22:17:44 obi Exp $
avia_av_event: $Id: avia_av_event.c,v 1.11 2003/10/26 16:32:51 obi Exp $
avia_av_proc: $Id: avia_av_proc.c,v 1.14 2004/01/21 20:02:29 carjay Exp $
Using /lib/modules/2.4.31-dbox2/misc/avia_gt.o
avia_gt_core: $Id: avia_gt_core.c,v 1.48 2004/12/20 01:01:22 carjay Exp $
avia_gt_core: autodetecting chip type... eNX
avia_gt_enx: $Id: avia_gt_enx.c,v 1.21 2003/09/30 05:45:35 obi Exp $
avia_gt_accel: $Id: avia_gt_accel.c,v 1.19 2003/09/30 05:45:35 obi Exp $
avia_gt_dmx: $Id: avia_gt_dmx.c,v 1.210 2004/06/26 16:08:15 carjay Exp $
avia_gt_ucode: loaded ucode v001A
avia_gt_ucode: ucode section filters disabled.
avia_gt_dmx: warning, misaligned queue 0 (is 0xFD200, size 65536), aligning...
avia_gt_gv: $Id: avia_gt_gv.c,v 1.39 2004/08/28 16:44:56 carjay Exp $
avia_gt_gv: set_input_size (width=720, height=576)
avia_gt_pcm: $Id: avia_gt_pcm.c,v 1.29 2004/01/29 19:38:20 zwen Exp $
avia_gt_pcm_set_rate(44100)
avia_gt_capture: $Id: avia_gt_capture.c,v 1.32 2003/09/30 05:45:35 obi Exp $
avia_gt_pig: $Id: avia_gt_pig.c,v 1.40 2003/09/30 05:45:35 obi Exp $
avia_gt_vbi: $Id: avia_gt_vbi.c,v 1.26 2003/08/01 17:31:22 obi Exp $
avia_gt_core: Loaded AViA eNX/GTX driver
Using /lib/modules/2.4.31-dbox2/misc/avia_gt_fb.o
avia_gt_fb: $Id: avia_gt_fb_core.c,v 1.54 2004/03/17 18:42:18 zwen Exp $
avia_gt_gv: set_input_mode (mode=2)
avia_gt_gv: set_input_size (width=720, height=576)
avia_gt_gv: set_input_mode (mode=2)
avia_gt_gv: set_input_size (width=720, height=576)
avia_gt_gv: set_input_mode (mode=2)
avia_gt_gv: set_input_size (width=720, height=576)
Console: switching to colour frame buffer device 82x32
avia_gt_fb: fb0: AViA eNX/GTX Framebuffer frame buffer device
Using /lib/modules/2.4.31-dbox2/misc/lcd.o
lcd.o: init lcd driver module
lcd.o: found KS0713/SED153X lcd interface
Using /lib/modules/2.4.31-dbox2/misc/avia_gt_lirc.o
avia_gt_lirc: $Id: avia_gt_lirc.c,v 1.14 2003/09/30 05:45:35 obi Exp $
avia_gt_ir: $Id: avia_gt_ir.c,v 1.30 2003/09/30 05:45:35 obi Exp $
Using /lib/modules/2.4.31-dbox2/misc/avia_gt_oss.o
avia_oss: $Id: avia_gt_oss.c,v 1.26 2004/05/31 22:56:02 carjay Exp $
avia_gt_pcm_set_rate(44100)
Using /lib/modules/2.4.31-dbox2/misc/avia_gt_v4l2.o
avia_gt_v4l2: $Id: avia_gt_v4l2.c,v 1.12 2003/09/30 04:54:03 obi Exp $
Using /lib/modules/2.4.31-dbox2/misc/at76c651.o
DVB: registering frontend 0:0 (Atmel AT76C651B with TUA6010XS)...
Using /lib/modules/2.4.31-dbox2/misc/ves1x93.o
Using /lib/modules/2.4.31-dbox2/misc/avia_av_napi.o
avia_av_napi.c: $Id: avia_av_napi.c,v 1.33 2004/03/11 15:30:27 derget Exp $
Using /lib/modules/2.4.31-dbox2/misc/avia_gt_napi.o
avia_gt_napi: $Id: avia_gt_napi.c,v 1.203 2005/01/05 05:49:56 carjay Exp $
Using /lib/modules/2.4.31-dbox2/misc/dvb2eth.o
Using /lib/modules/2.4.31-dbox2/misc/aviaEXT_alt.o
Using /lib/modules/2.4.31-dbox2/misc/avia_gt_proc.o
avia_gt_proc: $Id: avia_gt_proc.c, v 0.1.3 2003/09/25 12:24:00 Skars & Merandos
Exp $
avia_gt_proc: Description: GTX/ENX proc_dev Driver with proc_fs extension
options:
(demux reinit) enx_reset=1
(framer chan.) fc_reset=0
(clr avia reg) avia=1
(enx td trace) trace=0
(lock, unlock) spinlock=0
Schreiben ueber avia_gt.o
(delay) delay=10
Starting pid 83, console /dev/console: '/etc/init.d/start'

Please press Enter to activate this console. cdkVcInfo $Id: cdkVcInfo.c,v 1.0 20
02/09/26 20:48:26 alexW Exp $

Setting Date...
Thu Jan 1 01:00:00 CET 1970
Starting sectionsd...
$Id: sectionsd.cpp,v 1.184 2005/05/02 19:06:35 rasc Exp $
caching 168 hours
events are old 60min after their end time
Starting timerd...
Starting Camd..
warte auf evocamd (max. 5 Sekunden)
evocamd erfolgreich gestartet
Starting zapit...
$Id: zapit.cpp,v 1.371 2005/04/17 06:56:15 metallica Exp $
Couldn't open config file: /var/keys/newcamd-client.txt
============================================================
(compiled Oct 21 2005 21:11:30)
styled by TBT Team, Next Level version 1.01(dream-dbox2-Triple Dragon)
============================================================
/var/tuxbox/config/zapit/antiservices.xml: No such file or directory
[evocamd] Process id 192
/var/tuxbox/config/zapit/myservices.xml: No such file or directory
[camd] ca system id: 1722
Starting controld...
$Id: controld.cpp,v 1.117 2004/05/22 14:34:09 carjay Exp $

[controld] Boxtype detected: (3, Sagem D-BOX2)
Starting nhttpd...
[controld] /dev/dbox/avs0: No such file or directory
[controld] /dev/dbox/avs0: No such file or directory
[controld] /dev/dbox/avs0: No such file or directory
[controld] /dev/dbox/avs0: No such file or directory
[controld] setting VideoFormat to auto
[controld] /dev/dbox/avs0: No such file or directory
[nhttpd] Neutrino HTTP-Server starting..
[LCDFONT] initializing core...Starting neutrino...

[LCDFONT] adding font /share/fonts/micron.ttf...OK (Micron/Regular)
[LCDFONT] adding font /share/fonts/micron_bold.ttf...OK (Micron/Bold)
[LCDFONT] adding font /share/fonts/pakenham.ttf...OK (Pakenham/Regular)
[LCDFONT] Intializing font cache...
[neutrino] frameBuffer Instance created
812k video mem
avia_gt_gv: set_input_mode (mode=2)
avia_gt_gv: set_input_size (width=720, height=576)
[neutrino] Software update enabled
[neutrino] enable flash
[english.locale] missing entry: flashupdate.proxypassword_hint2
[english.locale] superfluous entry: fontsize.imageinfo_info
[english.locale] superfluous entry: fontsize.imageinfo_small
[english.locale] superfluous entry: imageinfo.creator
[english.locale] superfluous entry: imageinfo.date
[english.locale] superfluous entry: imageinfo.dokumentation
[english.locale] superfluous entry: imageinfo.forum
[english.locale] superfluous entry: imageinfo.head
[english.locale] superfluous entry: imageinfo.homepage
[english.locale] superfluous entry: imageinfo.image
[english.locale] superfluous entry: imageinfo.license
[english.locale] superfluous entry: imageinfo.version
[english.locale] superfluous entry: miscsettings.tuxtxt_cache
[english.locale] missing entry: movieplayer.bookmarkname_hint2
[english.locale] superfluous entry: servicemenu.imageinfo
[english.locale] superfluous entry: servicemenu.restart
[english.locale] superfluous entry: servicemenu.restart_failed
[english.locale] superfluous entry: servicemenu.restart_hint
[english.locale] superfluous entry: servicemenu.restart_refused_recording
[english.locale] superfluous entry: shutdown.recoding_query
[lcdd] time-skin not found -> using default...
[lcdd] weekday-skin not found -> using default...
[lcdd] date-skin not found -> using default...
[lcdd] month-skin not found -> using default...
[LCDFONT] initializing core...
[LCDFONT] adding font /share/fonts/12.pcf.gz...OK (Fix12/Regular)
[LCDFONT] adding font /share/fonts/14B.pcf.gz...OK (Fix14/Bold)
[LCDFONT] adding font /share/fonts/15B.pcf.gz...OK (Fix15/Bold)
[LCDFONT] Intializing font cache...
[LCDFONT] FTC_Face_Requester (Fix15/Bold)
[LCDFONT] FTC_Face_Requester (Fix14/Bold)
/dev/input/event1: No such file or directory
[neutrino] menue setup
[controld] setting VideoFormat to auto
[controld] /dev/dbox/avs0: No such file or directory
loading locales: scandir: No such file or directory
[neutrino] registering as event client
[controld] setting VideoFormat to auto
[controld] /dev/dbox/avs0: No such file or directory
[neutrino] initialized everything
zap failed!
[sectionsd] getUTC: read: Connection timed out
 

mgb

Inactive User
Joined
May 9, 2005
Messages
3,939
Likes
29
#10
It looks like there is something wrong with the avs (AudioVideoSwitch). There is a crash after Using /lib/modules/2.4.31-dbox2/misc/avs.o If avs is faulty the scart sockets cannot work.
 

mgb

Inactive User
Joined
May 9, 2005
Messages
3,939
Likes
29
#12
The problem is not the file, the problem is the chip on the mainboard that the driver cannot overtake.
Maybe you destroyed that chip by twiddling with the scart plugs on a powered box.
 

Dancer73

New Member +
Joined
Mar 13, 2005
Messages
86
Likes
0
#13
thanks mgb

Is it worth trying to get this repaired or would i be better off getting a new dbox
 
TEST
Top