• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Brand new ds lite dead ?

loady

DW Member +
Joined
Jul 27, 2005
Messages
1,328
Likes
3
#1
I bought this ds lite and have not even played a game in it yet, i was awaiting an m3 card arriving so had only turned the unit on and messed with it...when m3 card arrived i plugged it straight in and could browse around the menus though it felt a little flaky, i got some roms and dumped them on the sd card...when i went to power it up both screens flash white for 1 second then everything goes off...i have tried removing battery and everything and still no luck...anyone got any ideas ??

I did notice when i first got the unit that after a full initial charge the battery indicator was flashing, im not sure if that is to signify that it is low or whether its full...no lights come on when i plug the charger in...could it have been faulty form the offset, ie not charging ??
 

crackerchalk

DW Member ++
Joined
Aug 16, 2005
Messages
1,931
Likes
41
#3
I bought this ds lite and have not even played a game in it yet, i was awaiting an m3 card arriving so had only turned the unit on and messed with it...when m3 card arrived i plugged it straight in and could browse around the menus though it felt a little flaky, i got some roms and dumped them on the sd card...when i went to power it up both screens flash white for 1 second then everything goes off...i have tried removing battery and everything and still no luck...anyone got any ideas ??

I did notice when i first got the unit that after a full initial charge the battery indicator was flashing, im not sure if that is to signify that it is low or whether its full...no lights come on when i plug the charger in...could it have been faulty form the offset, ie not charging ??
Hi
That dont sound good if new back 2 the shop from whenst you got it
But before that
What happens when charger is put in(lights i mean)
Cos when new it aint fully charged
 

loady

DW Member +
Joined
Jul 27, 2005
Messages
1,328
Likes
3
#4
I think its the charger...initially it had some charge in it...i think it is now dead flat and the charger has never worked, no light comes on unit when charger is plugged in and the green led on the charger does not light, the charger is a cheapy oem poop that was bundles with it so i am hoping its that, they have sent out a replacement charger.