Thread: toyota avensis problem


Forum: Cars and Vans

hiya, got a problem witrh a toyota avensis 2003, its the later 2003 model, 2003 to 2006 model, what it is is you start it up enginemanagment light will be on and it will start ok a

Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    VIP Member
    Join Date
    Nov 2008
    Location
    yorkshire
    Posts
    1,706
    DW Cash
    53
    Downloads
    17
    Uploads
    0
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)

    toyota avensis problem

    hiya,
    got a problem witrh a toyota avensis 2003, its the later 2003 model, 2003 to 2006 model, what it is is you start it up enginemanagment light will be on and it will start ok and rev ok, then after a few seconds it will tick over fine but if you try to give it any throttle what so ever theres just no power there at all and can cut out, i got the elm 327 lead i think it is on the laptop and connected it to the car and it shows a p0093 error code, fuel system heavy leakage, after abit of research got told it was the common rail, so got one from the scrappers from a working engine, then at first it was still the same, so left it ticking over for about 15 minutes and it seemed to be fine, engine light was still on but would rev up no problem, so took it for a little drive and managed about a mile until it cut out, got it started straight away and drove the mile back again with out any problems but the enginer light was still on, so i cleared the code with the laptop and everything seemed fine, driving ok no loss of power , engine light stayed off thought it was fixed, come to it this morning start it up no engine light was on and revved up ok but after about 10 seconds the engine light came on and same problem, no power there what so ever, same error code p0093, still it will tick over ok but you give it throttle and nothing, soem times it will cut out but most of time you can hold your throttle down but revs dont go up at all, theres a load of black smoke coming from the exhaust aswell, think thats everything so was wondering has anyone ever had the p0093 error code and fixed it ? if so how ? thanks



  2. #2
    VIP Member
    Join Date
    Nov 2005
    Posts
    1,038
    DW Cash
    281
    Trophies
    Downloads
    13
    Uploads
    0
    Mentioned
    30 Post(s)
    Tagged
    0 Thread(s)

    Re: toyota avensis problem

    Have you checked the fuel filter? Sounds like the rail pressure is dropping as you are reving it.

    Thebigman

  3. #3
    VIP Member
    Join Date
    Nov 2008
    Location
    yorkshire
    Posts
    1,706
    DW Cash
    53
    Downloads
    17
    Uploads
    0
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)

    Re: toyota avensis problem

    it got changed not long ago but havent checked it since, should also add its a 2.0 d4d diesel engine, in case its helps

  4. #4
    DW Senior Member
    Join Date
    Jun 2010
    Posts
    352
    DW Cash
    25
    Downloads
    11
    Uploads
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: toyota avensis problem

    well i cant be sure but first thing i would do is leak test on the injectors over night

  5. #5
    VIP Member
    Join Date
    Nov 2005
    Location
    uk
    Posts
    3,819
    DW Cash
    85
    Downloads
    5
    Uploads
    0
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)

    Re: toyota avensis problem

    if its 2.0 d4d has it got the fuel pump with red and green solonoids at the back of it?? if yes they fail 170 for both from toyota

    other than that its pointing towards ur injectors m8

  6. #6
    VIP Member
    Join Date
    Nov 2008
    Location
    yorkshire
    Posts
    1,706
    DW Cash
    53
    Downloads
    17
    Uploads
    0
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)

    Re: toyota avensis problem

    hiya, thanks for the reply guys i have a fair bit to be getting on with thanks to your advice, i think its going to take a while but il post after i have abit more info after trying some things you have suggested, thanks

  7. #7
    VIP Member
    Join Date
    Nov 2008
    Location
    yorkshire
    Posts
    1,706
    DW Cash
    53
    Downloads
    17
    Uploads
    0
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)

    Re: toyota avensis problem

    Hiya, abit of a update, my mate tried doing some stuff on the car one day and ended up breaking the top of an injector, so had to get another injector so then had to get someone out to recode the injectors with the ecu etc, anyway while he had the computer on he said he had tested all the wiring and volltages to everything and said it was all ok and he seems to think it could be the egr valve, its still getting the same error code of p0093 and same sysmptoms, when the car starts from been cold it will idle great but as soon as you rev the car the engine light will come on and then it will start making a noise from the tappets it sounds like and really start struggling to stay on, but if you turn it off again and start it back up will idle grreat again until its revved up, but ifo you leave it idling until it warms up it will drive great, can reset the fault code and engine light will turn off and stay off, does anyone else think it could be the egr valve sticking as he said more than likely? Thanks
    or we have tried soaking it overnight aswell but that dint help anything, thanks

  8. #8
    VIP Member
    Join Date
    Nov 2005
    Location
    uk
    Posts
    3,819
    DW Cash
    85
    Downloads
    5
    Uploads
    0
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)

    Re: toyota avensis problem

    lol i would love to have his computer

    he's talking bull about testing wires unless he had a proper multimeter and a scope to test ?

  9. #9
    VIP Member
    Join Date
    Nov 2008
    Location
    yorkshire
    Posts
    1,706
    DW Cash
    53
    Downloads
    17
    Uploads
    0
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)

    Re: toyota avensis problem

    No he dint. I did wonder to be honest, he had one of them snapon diagnostic machhines, them where you have different keys to put in for different vehicles etc, thanks

  10. #10
    VIP Member
    Join Date
    Nov 2005
    Location
    uk
    Posts
    3,819
    DW Cash
    85
    Downloads
    5
    Uploads
    0
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)

    Re: toyota avensis problem

    lol i still say check ur diesel pump and injectors



Page 1 of 2 12 LastLast

User Tag List

Tags for this Thread

View Tag Cloud

Important Keywords:

cold, computer, diesel, drive, engine, error, filter, fuel, green, help, keys, laptop, power, problem, problems, system, update, working

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •